<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://seattle.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="keywords" content="wwe lacey evans, lacey evans marines, lacey evans interview, lacey evans pro wrestling" />
<meta property="fb:pages" content="312016212245379" />
<title>WWE’s Lacey Evans Wants To Be Champ In 2020, We Shouldn’t Doubt Her &#8211; CBS Seattle</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onIframesReady","onFormsReady","onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CBS Seattle &raquo; Feed" href="https://seattle.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Seattle &raquo; Comments Feed" href="https://seattle.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Seattle &raquo; WWE’s Lacey Evans Wants To Be Champ In 2020, We Shouldn’t Doubt Her Comments Feed" href="https://seattle.cbslocal.com/2019/12/20/lacey-evans-wwe-interview-marines-childhood/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://seattle.cbslocal.com/_static/??-eJytjzsOAjEMRC9EsChYSIE4Sz5midaxo3zE9QlZGipYicr22G80hkdSTrgiV6h3jFjA2aJInCEI7Kj5l1QK3EQq5n1vd/AThNGiX9mUkcT473CiNgcuEMU36hvzNuh1OzwOVDRsZszD5kNRPeRSJW14afVo0bIJpCjw8v9USH3iOv69xsvhOJ0mrSd9fgJ18p9z' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://seattle.cbslocal.com/_static/??-eJyNy0sKgDAMANELWaPFKi7Es9QYVEg/kIh4e+0FxO3wBq5sMEWlqKA7BRLARQwn9AyiN1ONIhV8sSMin2tJIpD9RkYpZPb64y0L8RujStFzmFo3dM1oXW8fIdQ5HQ==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://seattle.cbslocal.com/_static/??-eJydUltSwzAMvBCuyVDoF8NZFEWkJrLlsZWmuT12H3QgDBD+1pZ2tSvbTtGgBKWgVvfkKVtss2FBYBt57F3I1ks3cqmcGoyHAD0li7nczJG2m4Lu7E9CLiCPXb0qnMl1ZJR8ZFDKK8kRkv6B89V53ktSlKvK7bhiPPmWujP/BA27rAZBgaVfGaOkcMhkDrflfap3Rdq2hTiUKW2CNNusM9PGu7A+fdl4T/qx/YoXIn40V9obaQQcFvRXQGpFqqWhgOPF0mo7y2/kIQ11wrkfhSX945F/05UDpSk5XVr+JnylX3Btf/HPzePuadc09w/bd01LNTI=' type='text/css' media='all' />
<script type='text/javascript' src='https://seattle.cbslocal.com/_static/??-eJy1kEESwiAMRS8kYnW0K8ezUEgxNYRagk5vL3Zc6MrWGVeB8P/LJ/reKxtZgEXLGQIkbZukKFpDGtlSdqXVJd1HGlskWgfkdZdWeq6xm+XoKXvkpEN0mcqLcZO5FHXbvhM+0NcMw/gqXwUqoB+MwE95JoEKho2H4Yn+aKgy7yKxX7SYNrMVjJz+EQio3FjSokTGnSHhbd6Git5TbAwtGzEIWoLF372j8yAT4nUsiFM4Vvv6UFfVZrfvHnX2CnU='></script>
<link rel='https://api.w.org/' href='https://seattle.cbslocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://seattle.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://seattle.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://cbsloc.al/35L0PDI' />
<link rel="alternate" type="application/json+oembed" href="https://seattle.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseattle.cbslocal.com%2F2019%2F12%2F20%2Flacey-evans-wwe-interview-marines-childhood%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://seattle.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseattle.cbslocal.com%2F2019%2F12%2F20%2Flacey-evans-wwe-interview-marines-childhood%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="WWE’s Lacey Evans Wants To Be Champ In 2020, We Shouldn’t Doubt Her" /><meta property="og:image" content="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/12/lacey-evans-wwe-1.jpg?w=1024" /><meta property="og:image:secure_url" content="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/12/lacey-evans-wwe-1.jpg?w=1024" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="576" /><meta property="og:description" content="Lacey Evans has already beat the odds in life, going from an impoverished childhood to the Marines to WWE, but she&#039;s not satisfied." /><meta property="og:type" content="article" /><meta property="og:url" content="https://seattle.cbslocal.com/2019/12/20/lacey-evans-wwe-interview-marines-childhood/" /><meta property="article:published_time" content="2019-12-20T08:15:10+00:00" /><meta property="article:suggested-social-copy" content="Lacey Evans has already beat the odds in life, going from an impoverished childhood to the Marines to WWE, but she&#039;s not satisfied." /><meta property="article:publisher" content="https://www.facebook.com/CW11Seattle/" /><meta property="article:author" content="https://www.facebook.com/CW11Seattle/" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/12/lacey-evans-wwe-1.jpg?w=1024"><meta name="twitter:title" content="WWE’s Lacey Evans Wants To Be Champ In 2020, We Shouldn’t Doubt Her"/><meta name="twitter:description" content="Lacey Evans has already beat the odds in life, going from an impoverished childhood to the Marines to WWE, but she&#039;s not satisfied."/><meta name="twitter:site" content="/CW11Seattle/"/>
<link rel="canonical" href="https://newyork.cbslocal.com/2019/12/20/lacey-evans-wwe-interview-marines-childhood/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://seattle.cbslocal.com/2019/12/20/lacey-evans-wwe-interview-marines-childhood/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/seattle.cbslocal.com","url":"https:\/\/seattle.cbslocal.com","name":"CBS Seattle","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/seattle.cbslocal.com\/wp-content\/uploads\/sites\/15909838\/2018\/06\/2_cbs_seattle.png?w=209"}},"url":"https:\/\/seattle.cbslocal.com\/2019\/12\/20\/lacey-evans-wwe-interview-marines-childhood\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/seattle.cbslocal.com\/2019\/12\/20\/lacey-evans-wwe-interview-marines-childhood\/"},"headline":"WWE\u2019s Lacey Evans Wants To Be Champ In 2020, We Shouldn\u2019t Doubt Her","description":"Lacey Evans has already beat the odds in life, going from an impoverished childhood to the Marines to WWE, but she's not satisfied.","image":"https:\/\/seattle.cbslocal.com\/wp-content\/uploads\/sites\/15909838\/2019\/12\/lacey-evans-wwe-1.jpg?w=150&#038;h=150&#038;crop=1","keywords":["Sports","Chuck Carroll","lacey evans","Pro Wrestling","WWE","sports","WWE\u2019s Lacey Evans Wants To Be Champ In 2020, We Shouldn\u2019t Doubt Her"],"datePublished":"2019-12-20T08:15:10+00:00","dateModified":"2019-12-20T08:15:10+00:00"}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.SEATTLE","sports",["wweslaceyevanswantstobechampin2020weshouldntdoubther","post","article","sports","chuckcarroll","laceyevans","prowrestling","wwe","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("1");</script>
		<style type="text/css" id="wp-custom-css">
			
.single-post sup {
	vertical-align: super;
	font-size: 10px;
}

.postid-244620  .partner-container{
	display: none;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="Lacey Evans has already beat the odds in life, going from an impoverished childhood to the Marines to WWE, but she&#039;s not satisfied." />
<script>//<![CDATA[
//]]></script>

</head>

<body class="post-template-default single single-post postid-244963 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://seattle.cbslocal.com" id="header-logo"><img src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/06/2_cbs_seattle.png?w=209" alt="CBS Seattle" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="http://seattle.cbslocal.com/live" title="Live Videos" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Live Videos</strong></div></a><a href="http://seattle.cbslocal.com/photo-galleries/" title="Galleries" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Galleries</strong></div></a><a href="http://seattle.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="http://seattle.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Best Of</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2019/02/13/valentines-day-2019-best-romantic-destinations/" title="Valentine&#039;s Day 2019: The Best Romantic Destinations In America" class="cbs-thumbnail-link item-1550073614" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/02/gettyimages-98093473.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Valentine&#039;s Day 2019: The Best Romantic Destinations In America</strong><em class="description">Looking for the most romantic locations in the America? Check out the most romantic destinations in America!</em></div></a><a href="https://seattle.cbslocal.com/2018/04/27/5-new-spicy-southeast-asian-eateries-check-out-seattle/" title="5 New (And Spicy) Southeast Asian Eateries To Check Out In Seattle" class="cbs-thumbnail-link item-1524862257 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/04/photo-basilic-essentially-thai-yelp.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">5 New (And Spicy) Southeast Asian Eateries To Check Out In Seattle</strong><em class="description">Looking for your next great Southeast Asian meal in Seattle? These new spots are sure to satisfy your cravings.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Travel</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/08/GettyImages-466663843-17.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://seattle.cbslocal.com/2019/06/13/top-3-eco-friendly-vacation-spots/" title="Top 3 Eco-Friendly Vacation Spots" class="cbs-thumbnail-link item-1560449704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/06/gettyimages-598645380-e1537896793352.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 3 Eco-Friendly Vacation Spots</strong><em class="description">Check out the three best spots for an eco-friendly vacation!</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">CBS Entertainment</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/category/only-cbs/" title="CBS Entertainment" class="cbs-thumbnail-link item-1519667323" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/02/onlycbs.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Entertainment</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="http://seattle.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://www.cbssports.com/college-football/" title="NCAAF" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">NCAAF</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2019/12/20/fantasy-football-start-sit-week-16-philip-rivers-aaron-rodgers/" title="Fantasy Football Start And Sit Week 16: Start Philip Rivers Against Porous Raiders Defense" class="cbs-thumbnail-link item-1576861893" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/12/GettyImages-1194170332.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Fantasy Football Start And Sit Week 16: Start Philip Rivers Against Porous Raiders Defense</strong><em class="description">The Fantasy Football Today crew explains why Chargers QB Philip Rivers, who plays the Raiders, has to be in your lineup this week.</em></div></a><a href="https://seattle.cbslocal.com/2019/12/20/lacey-evans-wwe-interview-marines-childhood/" title="WWE’s Lacey Evans Wants To Be Champ In 2020, We Shouldn’t Doubt Her" class="cbs-thumbnail-link item-1576858510" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/12/lacey-evans-wwe-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">WWE’s Lacey Evans Wants To Be Champ In 2020, We Shouldn’t Doubt Her</strong><em class="description">Lacey Evans has already beat the odds in life, going from an impoverished childhood to the Marines to WWE, but she&#039;s not satisfied.</em></div></a><a href="https://seattle.cbslocal.com/2019/12/18/cbs-sports-classic-north-carolina-ucla-ohio-state-kentucky-how-to-watch/" title="2019 CBS Sports Classic: Matchups, Key Players And How To Watch" class="cbs-thumbnail-link item-1576686297" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/12/GettyImages-1192011150.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">2019 CBS Sports Classic: Matchups, Key Players And How To Watch</strong><em class="description">With the UNC-UCLA and #5 Ohio State-#6 Kentucky matchups, the 2019 CBS Sports Classic features some of college basketball&#039;s biggest name programs.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Galleries</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/photo-galleries/2017/11/12/falk-throws-3-tds-no-19-washington-state-beats-utah-33-25/" title="Falk throws 3 TDs, No. 19 Washington State beats Utah 33-25" class="cbs-thumbnail-link item-1510499358 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2017/11/gettyimages-873591258_master.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Falk throws 3 TDs, No. 19 Washington State beats Utah 33-25</strong><em class="description">Luke Falk threw for 311 yards and three touchdowns and No. 19 Washington State beat Utah 33-25 on Saturday.</em></div></a><a href="https://seattle.cbslocal.com/photo-galleries/2017/11/11/loves-3-tds-lead-stanford-past-no-9-washington-30-22/" title="Love&#039;s 3 TDs lead Stanford past No. 9 Washington 30-22" class="cbs-thumbnail-link item-1510412000 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2017/11/gettyimages-872711592_master.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Love&#039;s 3 TDs lead Stanford past No. 9 Washington 30-22</strong><em class="description">Love showed he had plenty left in the latest signature performance in his campaign for the Heisman Trophy.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link"><a href="http://seattle.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a></li><li class="menu-top-item item-3 w-link"><a href="https://seattle.cbslocal.com/live/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://seattle.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Headlines</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2019/02/13/valentines-day-2019-best-romantic-destinations/" title="Valentine&#039;s Day 2019: The Best Romantic Destinations In America" class="cbs-thumbnail-link item-1550073614" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/02/gettyimages-98093473.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Valentine&#039;s Day 2019: The Best Romantic Destinations In America</strong><em class="description">Looking for the most romantic locations in the America? Check out the most romantic destinations in America!</em></div></a><a href="https://seattle.cbslocal.com/2018/04/27/5-new-spicy-southeast-asian-eateries-check-out-seattle/" title="5 New (And Spicy) Southeast Asian Eateries To Check Out In Seattle" class="cbs-thumbnail-link item-1524862257 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/04/photo-basilic-essentially-thai-yelp.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">5 New (And Spicy) Southeast Asian Eateries To Check Out In Seattle</strong><em class="description">Looking for your next great Southeast Asian meal in Seattle? These new spots are sure to satisfy your cravings.</em></div></a><a href="https://seattle.cbslocal.com/2018/04/26/wine-dine-4-new-casual-spots-seattle-tasting-room-pizzeria/" title="Wine And Dine: 4 New Casual Spots In Seattle, With A Tasting Room And Pizzeria" class="cbs-thumbnail-link item-1524776513 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/04/mercato2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Wine And Dine: 4 New Casual Spots In Seattle, With A Tasting Room And Pizzeria</strong><em class="description">Looking for the Seattle wine bar of your dreams? We&#039;ve found a lineup of eateries and a vineyard worth checking out. Here are the newest places to check out the next time you&#039;ve got wine on the mind.</em></div></a><a href="https://seattle.cbslocal.com/2018/04/25/5-great-events-adventurous-seattle-weekend/" title="5 Great Events For An Adventurous Seattle Weekend" class="cbs-thumbnail-link item-1524691279 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/04/photo-pancakes-booze-art-show.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">5 Great Events For An Adventurous Seattle Weekend</strong><em class="description">The weekend is just around the corner, and there&#039;s plenty to see and do without leaving the city limits.</em></div></a><a href="https://seattle.cbslocal.com/2018/04/24/sweet-treats-check-out-top-5-doughnut-shops-seattle/" title="Sweet Treats: Check Out The Top 5 Doughnut Shops In Seattle" class="cbs-thumbnail-link item-1524603174 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/04/photo-jane-d-yelp.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Sweet Treats: Check Out The Top 5 Doughnut Shops In Seattle</strong><em class="description">Looking to sample the best doughnuts around town? We crunched the numbers to find the top doughnut spots in Seattle.</em></div></a><a href="https://seattle.cbslocal.com/2018/04/23/renting-seattle-what-will-1600-get-you/" title="Renting In Seattle: What Will $1,600 Get You?" class="cbs-thumbnail-link item-1524505848 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/04/3710-27th-place-w-photos-zumper.jpeg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Renting In Seattle: What Will $1,600 Get You?</strong><em class="description">Curious just how far your dollar goes in Seattle? We&#039;ve rounded up the latest rental offerings to get a sense of what to expect when it comes to scoring an apartment in Seattle with a budget of $1,600 / month.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link"><a href="http://cwseattle.cbslocal.com/" title="CW 11" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CW 11</strong></div></a></li><li class="menu-top-item item-6 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">More</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-5 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://seattle.cbslocal.com/category/travel/">Travel</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/08/GettyImages-466663843-17.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://seattle.cbslocal.com/2019/06/13/top-3-eco-friendly-vacation-spots/" title="Top 3 Eco-Friendly Vacation Spots" class="cbs-thumbnail-link item-1560449704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/06/gettyimages-598645380-e1537896793352.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 3 Eco-Friendly Vacation Spots</strong><em class="description">Check out the three best spots for an eco-friendly vacation!</em></div></a><a href="https://seattle.cbslocal.com/2019/04/04/final-four-guide-top-10-instagram-worthy-spots-in-minneapolis/" title="Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis" class="cbs-thumbnail-link item-1554411634" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/04/igworthy.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis</strong><em class="description">With thousands of Final Four fans heading to downtown Minneapolis in the coming days, you better believe the Instagram filters will be flying.</em></div></a><a href="https://seattle.cbslocal.com/2019/04/04/final-four-guide-best-breweries-minneapolis/" title="Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis" class="cbs-thumbnail-link item-1554411465" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/04/187774436.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis</strong><em class="description">Beer-lovers visiting Minneapolis for the Final Four won’t have to go far to find Minnesota’s most beloved beers. Walk in any direction out of U.S. Bank Stadium and you’ll probably find a bar or restaurant serving craft beers from the Twin Cities, the North Shore and other parts of “The Land of 10,000 Beers.&quot; But for hop heads seeking a more direct experience of the state’s brewing culture, there are a few places that need to be on your radar, because they’re well worth the Lyft ride.</em></div></a><a href="https://seattle.cbslocal.com/2019/04/04/final-four-guide-5-restaurants-near-u-s-bank-stadium/" title="Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium" class="cbs-thumbnail-link item-1554410992" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/04/107277389-e1538670804895.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium</strong><em class="description">In Minneapolis for the Final Four and want to try the restaurants where Minneapolitans love to eat? Look no further. Below are some of the most beloved spots in the City of Lakes within walking distance, or a short Lyft ride, from U.S. Bank Stadium.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/category/only-cbs/" title="CBS Entertainment" class="cbs-thumbnail-link item-1519667323" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/02/onlycbs.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Entertainment</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	
	
	<div id="info-search"><form action="https://seattle.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">WWE’s Lacey Evans Wants To Be Champ In 2020, We Shouldn’t Doubt Her</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">December 20, 2019 at 8:15 am</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://seattle.cbslocal.com/tag/chuck-carroll/">Chuck Carroll</a>, <a href="https://seattle.cbslocal.com/tag/lacey-evans/">lacey evans</a>, <a href="https://seattle.cbslocal.com/tag/pro-wrestling/">Pro Wrestling</a>, <a href="https://seattle.cbslocal.com/tag/wwe/">WWE</a></div></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div id='p0'></div><script type="text/plain" class="optanon-category-4" async data-anvp='{&quot;mcp&quot;:&quot;cbs&quot;,&quot;width&quot;:&quot;100%&quot;,&quot;height&quot;:&quot;100%&quot;,&quot;video&quot;:&quot;4263201&quot;,&quot;autoplay&quot;:true,&quot;titleVisible&quot;:false,&quot;accessKey&quot;:&quot;DVzl9QRzox3ZZsP9bNu5Li3X7obQOnqP&quot;,&quot;accessControl&quot;:{&quot;preview&quot;:false},&quot;pInstance&quot;:&quot;p0&quot;,&quot;plugins&quot;:{&quot;heartbeat&quot;:{&quot;account&quot;:&quot;cbslocal-global-unified&quot;,&quot;publisherId&quot;:&quot;cbslocal&quot;,&quot;jobId&quot;:&quot;sc_va&quot;,&quot;marketingCloudId&quot;:&quot;823BA0335567497F7F000101@AdobeOrg&quot;,&quot;trackingServer&quot;:&quot;cbsdigitalmedia.hb.omtrdc.net&quot;,&quot;customTrackingServer&quot;:&quot;cbsdigitalmedia.d1.sc.omtrdc.net&quot;,&quot;chapterTracking&quot;:false,&quot;version&quot;:&quot;1.5&quot;},&quot;comscore&quot;:{&quot;clientId&quot;:&quot;3000023&quot;,&quot;c3&quot;:&quot;Seattle.cbslocal.com&quot;},&quot;dfp&quot;:{&quot;clientSide&quot;:{&quot;adTagUrl&quot;:&quot;http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&amp;iu=\/4128\/CBS.SEATTLE&amp;ciu_szs&amp;impl=s&amp;gdfp_req=1&amp;env=vp&amp;output=xml_vast2&amp;unviewed_position_start=1&amp;url=[referrer_url]&amp;description_url=[description_url]&amp;correlator=[timestamp]&quot;,&quot;keyValues&quot;:{&quot;categories&quot;:&quot;[[CATEGORIES]]&quot;,&quot;program&quot;:&quot;[[PROGRAM_NAME]]&quot;,&quot;siteSection&quot;:&quot;featured&quot;}}}},&quot;shareLink&quot;:&quot;https:\/\/cbsloc.al\/35L0PDI&quot;,&quot;video-type&quot;:&quot;featured&quot;,&quot;token&quot;:&quot;default&quot;,&quot;expectPreroll&quot;:true,&quot;expectPrerollTimeout&quot;:5}' src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js'></script></div></section>
<div class="main-story-wrapper"><p><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd"><br />
<html><body><strong>(<a href="https://newyork.cbslocal.com/2019/12/20/lacey-evans-wwe-interview-marines-childhood/">CBS New York</a>/CBS Local) &#8212;</strong> Lacey Evans wants to be on top of the women&rsquo;s division in WWE. Call it her new year&rsquo;s resolution heading into 2020.</p>
<p>And who are we to doubt her? She&rsquo;s already beaten the odds.</p>
<p>The 29-year-old managed to escape the trappings of an impoverished childhood chock full of demons that ravaged her family. Both of her parents struggled with substance abuse, and her father ultimately died of an overdose. She also had a front-row seat to her mother&rsquo;s battle with depression.</p>
<p>According to Evans, hers is a family tree devoid of hard work and success.</p>
<p>She didn&rsquo;t know much about what she wanted in life, but she did know from a young age that she wanted her apple to fall far, very far, from that tree. The thought of spiraling into alcohol and drugs repulsed her after witnessing the way they can corrupt human life.</p>
<p>Often in the morning on the way out the door to school she would walk by her father who was still in a semi-comatose state following illegal indulgences the night before. Viewing the heavy scene at a fragile age was motivation to stay on the straight and narrow.</p>
<p>Wanting to spread her wings beyond a broken home, Evans began throwing herself into sports. It didn&rsquo;t matter whether she was picked first or last or wasn&rsquo;t picked at all. Like clockwork, she would always show up the next day. Perhaps she was driven by a fear that walking away from a challenge would open the door for her to follow her family into a dark abyss.</p>
<p>Her headstrong attitude prepared her for her first big post-graduation career move, when she joined the United States Marine Corps. Interestingly, Evans&#8217; decisions growing up exuded confidence, but she never felt as though she had any until she enlisted. The structure of the Corps began to mold her into the woman she is today and heavily influenced the character millions view on television each week.</p>
<p>Really, every fan of the sassy Southern belle owes the Corps a debt of gratitude. Because without her time there, she may never have discovered pro wrestling. Her staff sergeant wrestled on local independent shows, and a curious Evans went once just to check things out. Rather quickly, she became intrigued and wondered whether she had what it took to compete in the ring.</p>
<p>It wasn&rsquo;t long before she had her answer.</p>
<p>Within two years, Evans was under contract with WWE and honing her craft inside an <em>NXT</em> ring. She began rising through the ranks and eventually made her main roster debut as the first entrant in the 2019 WWE Women&rsquo;s Royal Rumble. The first impression was a good one, as she eliminated two others from the match and lasted nearly 30 minutes before her night was ended by Charlotte Flair.</p>
<p>Her first major feud came a few months later as she tangled with Becky Lynch following WrestleMania. There had been rumblings that the company was high on Evans, given her background as a Marine and mother to a young daughter. At the time, Lynch was on fire, and there is no other way to interpret throwing a rookie into a program with the company&rsquo;s top star than as a major vote of confidence.</p>
<p>The hard work continues paying off, and there are no plans to pump the brakes and slow down anytime soon.</p>
<p>I had the opportunity to catch up with Evans recently as she teamed up with talk show host Montel Williams, also a former Marine, to assist a military family in need. From the set of <em>Military Makeover</em>, she opened up about her troubled childhood, shielding her daughter from the same dire circumstances, her background in construction, honoring service members with <em>Tribute to the Troops,</em> her entrance into wrestling, and the goals she has set for herself in the new year.</p>
<p><em><strong>&gt;&gt;READ: <a href="/tag/pro-wrestling/" rel="nofollow">Latest from the world of Pro Wrestling</a></strong></em></p>
<p><strong>Your story is really remarkable in the way that you&#8217;ve been able to pull yourself up from the bootstraps and make something of yourself. You grew up with a really rough upbringing, a broken home with substance abuse and depression.&nbsp; What gave you the strength to be able to do all that?</strong></p>
<p>I honestly, I don&#8217;t know. If I had to guess, with having as many siblings as I did&#8230; I lost my father to overdose. My mother struggled with depression and addiction, and I just stayed in sports. I stayed busy. It didn&#8217;t matter if I didn&#8217;t get picked up, I still went the next day. So, you go out to wrestling practice, you work your ass off, you work in school all day. Now they forget to pick you up.</p>
<p>I have a choice, either I can walk home and wallow in my own misery and pity, or I can go back to school, catch the school bus, and get back into practice, regardless if I have a ride home or not. I think that sports really saved me, because it kept my head straight. No drugs, no alcohol, no nothing. I stayed on a straight path, and I just stayed in school, and I just kept my mind busy.</p>
<p>I also got a job as soon as I legally could. I made sure I could get there even if I had to walk. Finally, I joined the Marine Corps, which was probably the best decision I&#8217;ve ever made in my life, because it taught me the confidence and the discipline and the initiative that I have today.</p>
<p>I&#8217;ve always had the option to not work hard, because I don&#8217;t come from a family of hard workers or successful&#8230; It was always drugs and depression. They let life really get the best of them. &hellip; I didn&#8217;t know what I wanted to be. I just knew what I didn&#8217;t want to be, because every morning when I woke up, when I had to wake myself up for school and catch the bus and continue to stay sober and stay on a right path, I&#8217;d look around, and with my father being addicted and passed out. That was an option. I had that option. I could become that, or I could get my ass on the school bus, and I can continue to work hard, and I can continue to show up to practice and make the right decisions. So, I took it one day at a time, and I just made sure to make the right decisions and stay busy.</p>
<p><strong>It doesn&#8217;t sound like you put up with a whole lot of mess growing up. You were on a mission to do what it is that you wanted to do and stay on the straight and narrow and make something of yourself. Your character in the ring, Lacey Evans, doesn&#8217;t put up with a whole lot of mess either. How much of the real you is actually part of the Lacy character?</strong></p>
<p>Oh, a lot of it. Lacey Evans is a confident, classy, sophisticated son of a gun. She&#8217;s got a sharp tongue. She&#8217;s not afraid. She&#8217;s got grit and she&#8217;s not afraid of anything. She knows what she&#8217;s capable of. One thing, without a shadow of a doubt, she will never give up. It does not matter what she faces.</p>
<p>It&#8217;s cool to be able to show that side of a woman and show the beauty and the feminine qualities of a woman. I always say, I could bake a pie just as good as I can fire a weapon, because women are capable of anything. I bring that to the table to show them what women are capable of, and Lacey Evans is just a firecracker and with a bright red lip and just don&#8217;t piss her off, because you don&#8217;t want her to put her boots back on, that&#8217;s for sure.</p>
<p><strong>You&#8217;ve spoken a lot about your daughter, and I would think that you&#8217;re trying hard to be a role model for her and show her if you work hard you can achieve great things in life. Are you proud of the path that you&#8217;ve laid ahead of her?</strong></p>
<p>Absolutely. I&#8217;m proud, too, that I got to show her that it doesn&#8217;t matter where you come from, that you are responsible and capable of changing where you go. It doesn&#8217;t matter the cards you were dealt. You get to choose what game you play.</p>
<p>The only thing that I&#8217;m scared of is I didn&#8217;t have much growing up. I lived in tents, I lived in trailers, I lived in terrible, terrible situations. My baby doesn&#8217;t have to live like that. My biggest fear is if I lost everything today, everything with WWE and how great I&#8217;m doing and the money and everything that comes with it, I would be okay. I know that, because I know that because I come from nothing. You know what I mean? I have no fear of going back to that, because I know I can survive, and I know I can find happiness. Every day it&#8217;s your choice to be happy and make what you have work.</p>
<p>So, the only thing I could say is when you ask, am my proud of what I&#8217;ve shown my daughter, is I&#8217;m scared to death that if something happens, God forbid, I&#8217;m wondering how she would take it.</p>
<p><strong>Let me ask you another question along the same lines. In the ring, you sometimes, you have this villainous persona. That&#8217;s just who Lacey can be, right? But then at home you&#8217;re the sweet, loving mother who&#8217;s laying out this wonderful example for her daughter. What kind of conversations have the two of you had about what it is that she sees you do in the ring versus who you are outside of it?</strong></p>
<p>Don&#8217;t get it twisted. When I come home, I pick her up, and I love on her. And she gets everything that she needs, because she&#8217;s my baby. But I make sure to instill that same discipline, that same grit, to make sure she knows what she&#8217;s capable of, and just lead that strong little girl so my daughter is confident and strong and hard-working. But she&#8217;s completely aware when Lacey has her on-TV moments, my baby is aware and she knows the difference very well.</p>
<p><strong>2020 is right around the corner. Everybody is setting goals with new year&#8217;s resolutions. What are your goals for the new year?</strong></p>
<p>Probably to become champ and get more opportunities to use my platform to show people what you&#8217;re capable of, no matter how hard your life is. I know sometimes things hurt really bad and I know there are a lot of bad things that are happening, and you feel so down and out on yourself. But trust me when I tell you, coming from where I come from and what I&#8217;ve been through, you are capable of anything. If I have to become a champion to tell the world that they are capable of anything, as long as they continue to fight, make a plan, and push forward, then that&#8217;s what I want to do. That is my goal.</p>
<p><strong>(Helping a military family in need) has to be really a personal thing for you, given your background in the Marines. You must really identify with this family [you&rsquo;re helping on <em>Military Makeover</em>].</strong></p>
<p>Absolutely. I know what not only the veterans go through, but their families. Life&#8217;s hard in general for everybody involved, across the world. But as a veteran, I know when you&#8217;re away from your families or when you&#8217;re giving everything and your days are long. I know the pay that they get, and it&#8217;s not like they can get overtime. They give so much, not only time, but their physical body. They give their mental state, their mental wellness. They give their physical wellness. Everything, they just give to our nation. To be able to come in, as a veteran myself, and help these families in need is just a blessing.</p>
<p><strong>You just did <em>Tribute To The Troops</em>. Can you express to those of us who don&#8217;t come from a military family the importance of putting on events like this and what it does to boost morale?</strong></p>
<p>It&#8217;s very important. Our military members, they give, like I said&#8230; there&#8217;s long days. When I was active duty, we started at 0330 in the morning. We didn&#8217;t go to bed until late that night&hellip; Whether they&#8217;re deployed or not, even active duty non-deployment, they&#8217;re working their tail off. Their jobs are tough, and their families go through a lot. So <em>Tribute To The Troops</em>, when we get an opportunity to all get in there and while they&#8217;re boots on the ground, dressed in cammies, ready to rock, and they get to take time out of their day to watch us perform live, it&#8217;s just something to the troops to let them see that they&#8217;re important. What they do is important to us, and we are letting them relax and just enjoy the entertainment that WWE brings and tell them thank you. It&#8217;s an entire day of giving back to them and making them feel special and making them realize that what they&#8217;re doing for us is just, we can&#8217;t repay them.</p>
<p><em>Chuck Carroll is former pro wrestling announcer and referee turned sports media personality. He once <a title="Robert Griffin III Receives A Special Award: Raw, Nov. 26, 2012" href="http://www.wwe.com/videos/robert-griffin-iii-receives-a-special-award-raw-nov-26-2012-26072063" target="_blank" rel="nofollow">appeared on Monday Night RAW</a> when he presented Robert Griffin III with a WWE title belt in the Redskins locker room. </em></p>
<p><em>Follow him on Twitter <a href="https://twitter.com/chuckcarrollwlc" rel="nofollow">@ChuckCarrollWLC</a>.</em></body></html></p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/35L0PDI"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/35L0PDI"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/35L0PDI"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CW11Seattle/" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/CW11Seattle/" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://seattle.cbslocal.com/2019/12/03/young-nurse-pursues-her-dreams-while-living-with-ms/" title="Young Nurse Pursues Her Dreams While Living With MS" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/12/genen1111.png?resize=55%2C55&#038;ssl=1" alt="Young Nurse Pursues Her Dreams While Living With MS" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2019/12/03/young-nurse-pursues-her-dreams-while-living-with-ms/" title="Young Nurse Pursues Her Dreams While Living With MS" class="bump-view" data-bump-view="tp">Young Nurse Pursues Her Dreams While Living With MS</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2019/12/06/patriots-chiefs-matchup-preview-patrick-mahomes-tom-brady-afc-playoffs/" title="Chiefs-Patriots Previews: Can Pats Defense Contain Patrick Mahomes?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/12/patrick-mahomes-chiefs-1.jpg?resize=55%2C55&#038;ssl=1" alt="Chiefs-Patriots Previews: Can Pats Defense Contain Patrick Mahomes?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2019/12/06/patriots-chiefs-matchup-preview-patrick-mahomes-tom-brady-afc-playoffs/" title="Chiefs-Patriots Previews: Can Pats Defense Contain Patrick Mahomes?" class="bump-view" data-bump-view="tp">Chiefs-Patriots Previews: Can Pats Defense Contain Patrick Mahomes?</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2016/12/27/best-views-of-space-needle-fireworks-on-nye/" title="Best Views of Space Needle Fireworks on NYE" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2011/12/107431629.jpg?resize=55%2C55&#038;ssl=1" alt="Best Views of Space Needle Fireworks on NYE" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2016/12/27/best-views-of-space-needle-fireworks-on-nye/" title="Best Views of Space Needle Fireworks on NYE" class="bump-view" data-bump-view="tp">Best Views of Space Needle Fireworks on NYE</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2019/11/27/keltie-knight-entertainment-tonight-interview/" title="&#039;It&#039;s Such A Big Deal&#039;: Entertainment Tonight&#039;s Keltie Knight On Covering Macy&#039;s Thanksgiving Day Parade" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/11/GettyImages-937506646-e1574871327644.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;It&#039;s Such A Big Deal&#039;: Entertainment Tonight&#039;s Keltie Knight On Covering Macy&#039;s Thanksgiving Day Parade" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2019/11/27/keltie-knight-entertainment-tonight-interview/" title="&#039;It&#039;s Such A Big Deal&#039;: Entertainment Tonight&#039;s Keltie Knight On Covering Macy&#039;s Thanksgiving Day Parade" class="bump-view" data-bump-view="tp">&#039;It&#039;s Such A Big Deal&#039;: Entertainment Tonight&#039;s Keltie Knight On Covering Macy&#039;s Thanksgiving Day Parade</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2019/12/06/the-l-word-generation-q-jennifer-beals-katherine-moennig/" title="&#039;The L Is Still Love&#039;: Jennifer Beals And Katherine Moennig Discuss &#039;The L Word: Generation Q&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/12/LWGQ_101_0107_R.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;The L Is Still Love&#039;: Jennifer Beals And Katherine Moennig Discuss &#039;The L Word: Generation Q&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2019/12/06/the-l-word-generation-q-jennifer-beals-katherine-moennig/" title="&#039;The L Is Still Love&#039;: Jennifer Beals And Katherine Moennig Discuss &#039;The L Word: Generation Q&#039;" class="bump-view" data-bump-view="tp">&#039;The L Is Still Love&#039;: Jennifer Beals And Katherine Moennig Discuss &#039;The L Word: Generation Q&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2011/12/19/christmas-volunteer-opportunities-in-puget-sound/" title="Christmas Volunteer Opportunities in Puget Sound " class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2011/12/107759173.jpg?resize=55%2C55&#038;ssl=1" alt="Christmas Volunteer Opportunities in Puget Sound " data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2011/12/19/christmas-volunteer-opportunities-in-puget-sound/" title="Christmas Volunteer Opportunities in Puget Sound " class="bump-view" data-bump-view="tp">Christmas Volunteer Opportunities in Puget Sound </a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2019/12/06/xavier-woods-wwe-torn-achilles-injury-upupdowndown-new-day-feel-the-power/" title="WWE&#039;s Xavier Woods Embraces Inner Media Maven As Achilles Heals" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/12/xavier-woods-wwe-1.jpg?resize=55%2C55&#038;ssl=1" alt="WWE&#039;s Xavier Woods Embraces Inner Media Maven As Achilles Heals" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2019/12/06/xavier-woods-wwe-torn-achilles-injury-upupdowndown-new-day-feel-the-power/" title="WWE&#039;s Xavier Woods Embraces Inner Media Maven As Achilles Heals" class="bump-view" data-bump-view="tp">WWE&#039;s Xavier Woods Embraces Inner Media Maven As Achilles Heals</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
										<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CW11Seattle/" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/CW11Seattle/" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">Entertainment</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="https://seattle.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://seattle.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/about-us/" title="About Us" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">About Us</strong></div></a><a href="http://seattle.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://seattle.cbslocal.com" class="logo"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Seattle" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2019 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=seattle.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://policies.cbslocal.com/privacy/current.html#video-services" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-50590" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50590"><a href="http://policies.cbslocal.com/privacy/current.html">Privacy Policy</a></li>
<li id="menu-item-50591" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50591"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-174999" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-174999"><a href="http://policies.cbslocal.com/privacy/current.html#cali-visitors">Your California Privacy Rights</a></li>
<li id="menu-item-175000" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-175000"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-81759" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-81759"><a href="http://policies.cbslocal.com/privacy/current.html#onlinead">Ad Choices</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='all-css-0' href='https://seattle.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1563271880g' type='text/css' media='all' />
<script src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201951'></script>
<script>
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
</script>
<script type='text/javascript' src='https://seattle.cbslocal.com/_static/??-eJyNjUEOgzAMBD9EMBECThVPqUhiKofYiRpHfB9649jjSDs7cBbjsyiKAjdTUvuQVIioZfMHvEk8uEYpwL55dDkfBtlh6Jmkj7WDv309SRW/RokxkeDz4V6lFvD26g+fhZVfdlrmxdphnOIFg6c/kg=='></script>
<script type='text/javascript' src='https://stats.wp.com/e-201951.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.0',blog:'162246008',post:'244963',tz:'-8',srv:'seattle.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246008', '244963' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>