<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://seattle.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="florida georgia football 2020, florida vs georgia, florida vs georgia football, florida georgia game, florida georgia football game," />
<meta name="keywords" content="florida georgia football 2020, florida vs georgia, florida vs georgia football, florida georgia game, florida georgia football game," />
<meta property="fb:pages" content="312016212245379" />
<title>#8 Florida Vs #5 Georgia: With Strong Game Saturday, &#8216;Kyle Trask Will Be Talked About In Heisman Trophy Race,&#8217; Says CBS&#8217; Rick Neuheisel &#8211; CBS Seattle</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="CBS Seattle &raquo; Feed" href="https://seattle.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Seattle &raquo; Comments Feed" href="https://seattle.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Seattle &raquo; #8 Florida Vs #5 Georgia: With Strong Game Saturday, &#8216;Kyle Trask Will Be Talked About In Heisman Trophy Race,&#8217; Says CBS&#8217; Rick Neuheisel Comments Feed" href="https://seattle.cbslocal.com/2020/11/05/florida-georgia-football-2020-rick-neuheisel-cbs/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://seattle.cbslocal.com/_static/??-eJytj0sOwjAMRC9EsKpSBAvEWfIxJapjR/mI6xNSNqygEivbY7/RGB5RWeGCXKDcMWAGa7IisZrAs6XqXlLOcBMpmPat3cFPEAaDbmVjQhLtvsOR6uw5QxBXqW3026DV7XA/UEGznjF1mw9FtZBLkbjhpdWjBsPakyLPy/9TIbWJS//3Gi7DdBrG4+E8Tk91nZ9e' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://seattle.cbslocal.com/_static/??-eJyNy0sKgDAMANELWWPFUlyIZ6kxqJB+IBHx9toLiNvhDVzFYE5KSUF3iiSAixjOGBhEb6YWRRr4YkdCPteaRKCEjYxSLBz0x1sX4jcmlarnOFnnh27snbcPIdU5HQ==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://seattle.cbslocal.com/_static/??-eJydUllOxDAMvRCZFE2FxAfiLG5qOqFOHCXulN4eZxZGULGUP29vsRM7J+M4CkaxcsCAxbquGGIHZBNNg4/FBu4n0s5pwASIMGC2rmhlSdjuNLqzPxH56Gjqa0kxs+/RCIZEIFg2ghNk+QPmq/Ny4CyOryy3dIM8hg77M/4UGvJFjAMB4mHjGrqFd4TmeDvep36v1LZT4KgqXYa82CIL4S74uH17vfiA8nH9Gq9IwmSusFeUBKr8uGtWFC/gsGOutkYN3i62Nltaf6UAeawK53nHxPkfD/0bLx8xz9nL2vI3B6gUl7xCnsPT/UPTNs1+37bvIcc2sA==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://seattle.cbslocal.com/_static/??-eJydT0ESwiAM/JA01TLeHN+CQCsYAjag09+LHQ/2ZOtpJ5vsbhaeSehI2VKGfLXBMugLC4xaITjSWEylPEOKOPUOsQmOGs87WCv0qxQJy+CIIURTsG6UmcUVxOPw7bCwvhc7Th/YHDEfiKBIDXZ82y0IUTNuOaZNXftCOrtI/FfnHw9ZrBNlrr7ncNofW9m2XSelfwF8rKe2'></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.5.2' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://seattle.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILQxpm3ZAfEuXRl2qtJ1Iyn6fCnHhwm6W/WzDsXdYslE2sI0SKeCqnRR0ApxRqm9WVHB+I+UX9YlzH/UC/4qND1JWJ6fkz8XTGIVOO7vUwFkhFV+lJQf7QPaZ+Mo28Uj3YVyG622apzG+AQq+VNQ='></script>
<link rel="https://api.w.org/" href="https://seattle.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://seattle.cbslocal.com/wp-json/wp/v2/posts/249917" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://seattle.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://seattle.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.2" />
<link rel='shortlink' href='https://cbsloc.al/38f1iln' />
<link rel="alternate" type="application/json+oembed" href="https://seattle.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseattle.cbslocal.com%2F2020%2F11%2F05%2Fflorida-georgia-football-2020-rick-neuheisel-cbs%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://seattle.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseattle.cbslocal.com%2F2020%2F11%2F05%2Fflorida-georgia-football-2020-rick-neuheisel-cbs%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="#8 Florida Vs #5 Georgia: With Strong Game Saturday, &#039;Kyle Trask Will Be Talked About In Heisman Trophy Race,&#039; Says CBS&#039; Rick Neuheisel" /><meta property="og:image" content="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/11/GettyImages-1179907653-25.jpg?w=1500" /><meta property="og:image:secure_url" content="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/11/GettyImages-1179907653-25.jpg?w=1500" /><meta property="og:image:width" content="1500" /><meta property="og:image:height" content="1000" /><meta property="og:description" content="The CBS Sports college football analyst is leaning towards a Florida win but, says that the recent history of Georgia wins means the Gators senior QB will have to lead his team to the win." /><meta property="og:type" content="article" /><meta property="og:url" content="https://seattle.cbslocal.com/2020/11/05/florida-georgia-football-2020-rick-neuheisel-cbs/" /><meta property="article:published_time" content="2020-11-05T12:38:15+00:00" /><meta property="article:suggested-social-copy" content="The CBS Sports college football analyst is leaning towards a Florida win but, says that the recent history of Georgia wins means the Gators senior QB will have to lead his team to the win." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Only CBS,Sports" /><meta property="article:publisher" content="https://www.facebook.com/CW11Seattle/" /><meta property="article:author" content="https://www.facebook.com/CW11Seattle/" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/11/GettyImages-1179907653-25.jpg?w=1500"><meta name="twitter:title" content="#8 Florida Vs #5 Georgia: With Strong Game Saturday, &#039;Kyle Trask Will Be Talked About In Heisman Trophy Race,&#039; Says CBS&#039; Rick Neuheisel"/><meta name="twitter:description" content="The CBS Sports college football analyst is leaning towards a Florida win but, says that the recent history of Georgia wins means the Gators senior QB will have to lead his team to the win."/><meta name="twitter:site" content="/CW11Seattle/"/>
<link rel="canonical" href="https://miami.cbslocal.com/2020/11/05/florida-georgia-football-2020-rick-neuheisel-cbs/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://seattle.cbslocal.com/2020/11/05/florida-georgia-football-2020-rick-neuheisel-cbs/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/seattle.cbslocal.com","url":"https:\/\/seattle.cbslocal.com","name":"CBS Seattle","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/seattle.cbslocal.com\/wp-content\/uploads\/sites\/15909838\/2018\/06\/2_cbs_seattle.png?w=209"}},"url":"https:\/\/seattle.cbslocal.com\/2020\/11\/05\/florida-georgia-football-2020-rick-neuheisel-cbs\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/seattle.cbslocal.com\/2020\/11\/05\/florida-georgia-football-2020-rick-neuheisel-cbs\/"},"headline":"#8 Florida Vs #5 Georgia: With Strong Game Saturday, &#8216;Kyle Trask Will Be Talked About In Heisman Trophy Race,&#8217; Says CBS&#8217; Rick Neuheisel","description":"The CBS Sports college football analyst is leaning towards a Florida win but, says that the recent history of Georgia wins means the Gators senior QB will have to lead his team to the win.","image":"https:\/\/seattle.cbslocal.com\/wp-content\/uploads\/sites\/15909838\/2020\/11\/GettyImages-1179907653-25.jpg?w=150&#038;h=150&#038;crop=1","keywords":["Only CBS","Sports","College Football","Ryan Mayer","SEC on CBS","sports","#8 Florida Vs #5 Georgia: With Strong Game Saturday, 'Kyle Trask Will Be Talked About In Heisman Trophy Race,' Says CBS' Rick Neuheisel"],"datePublished":"2020-11-05T12:38:15+00:00","dateModified":"2020-11-05T12:38:15+00:00"}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.SEATTLE","sports",["8floridavs5georgiawithstronggamesaturdaykyletraskwillbetalkedaboutinheismantrophyracesayscbsrickneuheisel","post","article","onlycbs","sports","collegefootball","ryanmayer","seconcbs","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("1");</script>
		<style type="text/css" id="wp-custom-css">
			
.single-post sup {
	vertical-align: super;
	font-size: 10px;
}

.postid-244620  .partner-container{
	display: none;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="The CBS Sports college football analyst is leaning towards a Florida win but, says that the recent history of Georgia wins means the Gators senior QB will have to lead his team to the win." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-249917 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://seattle.cbslocal.com" id="header-logo"><img src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/06/2_cbs_seattle.png?w=209" alt="CBS Seattle" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="http://seattle.cbslocal.com/live" title="Live Videos" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Live Videos</strong></div></a><a href="http://seattle.cbslocal.com/photo-galleries/" title="Galleries" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Galleries</strong></div></a><a href="http://seattle.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="http://seattle.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Best Of</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2020/05/22/quarantine-cooking-nonstick-cookware-guide/" title="Quarantine Cooking: Your Essential Nonstick Cookware Guide" class="cbs-thumbnail-link item-1590161120" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/nonstickpans.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Cooking: Your Essential Nonstick Cookware Guide</strong><em class="description">Step up your quarantine cooking with this guide to nonstick cookware.</em></div></a><a href="https://seattle.cbslocal.com/2020/05/22/how-to-6-easy-steps-to-make-homemade-soft-pretzels/" title="How To: 6 Easy Steps To Make Homemade Soft Pretzels" class="cbs-thumbnail-link item-1590161082" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/homemadepretzel.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How To: 6 Easy Steps To Make Homemade Soft Pretzels</strong><em class="description">Learn how to make your own homemade soft pretzels with these six easy steps!</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Travel</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/08/GettyImages-466663843-17.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://seattle.cbslocal.com/2019/06/13/top-3-eco-friendly-vacation-spots/" title="Top 3 Eco-Friendly Vacation Spots" class="cbs-thumbnail-link item-1560449704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/06/gettyimages-598645380-e1537896793352.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 3 Eco-Friendly Vacation Spots</strong><em class="description">Check out the three best spots for an eco-friendly vacation!</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">CBS Entertainment</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/category/only-cbs/" title="CBS Entertainment" class="cbs-thumbnail-link item-1519667323" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/02/onlycbs.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Entertainment</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="http://seattle.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://www.cbssports.com/college-football/" title="NCAAF" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">NCAAF</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2020/11/05/florida-georgia-football-2020-rick-neuheisel-cbs/" title="#8 Florida Vs #5 Georgia: With Strong Game Saturday, &#039;Kyle Trask Will Be Talked About In Heisman Trophy Race,&#039; Says CBS&#039; Rick Neuheisel" class="cbs-thumbnail-link item-1604608695" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/11/GettyImages-1179907653.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">#8 Florida Vs #5 Georgia: With Strong Game Saturday, &#039;Kyle Trask Will Be Talked About In Heisman Trophy Race,&#039; Says CBS&#039; Rick Neuheisel</strong><em class="description">The CBS Sports college football analyst is leaning towards a Florida win but, says that the recent history of Georgia wins means the Gators senior QB will have to lead his team to the win.</em></div></a><a href="https://seattle.cbslocal.com/2020/11/05/nfl-week-9-nfc-north-picks-packers-bears-lions-vikings/" title="NFL Week 9 NFC North Picks: &quot;I Do Not See This Current Bears Team Going Into Tennessee And Beating Them,&quot; Says CBS Chicago&#039;s Matt Zahn" class="cbs-thumbnail-link item-1604598147" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/11/nick-foles-bears-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">NFL Week 9 NFC North Picks: &quot;I Do Not See This Current Bears Team Going Into Tennessee And Beating Them,&quot; Says CBS Chicago&#039;s Matt Zahn</strong><em class="description">CBS Chicago sports anchor Steve Zahn discusses NFC North matchups, with the Bears hoping to end a losing streak and the Vikings looking to climb back into the playoff race.</em></div></a><a href="https://seattle.cbslocal.com/2020/11/05/rowdy-gaines-international-swimming-league-michael-phelps/" title="Rowdy Gaines: &#039;Team USA Swimming Has Been #1 In The World Since 1956, No Other Sport Can Claim That Excellence&#039;" class="cbs-thumbnail-link item-1604593956" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/11/GettyImages-149235043-e1604591534944.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Rowdy Gaines: &#039;Team USA Swimming Has Been #1 In The World Since 1956, No Other Sport Can Claim That Excellence&#039;</strong><em class="description">The Hall of Fame swimmer discusses the International Swimming League and explains why Michael Phelps is the greatest swimmer of all-time.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Galleries</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/photo-galleries/2017/11/12/falk-throws-3-tds-no-19-washington-state-beats-utah-33-25/" title="Falk throws 3 TDs, No. 19 Washington State beats Utah 33-25" class="cbs-thumbnail-link item-1510499358 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2017/11/gettyimages-873591258_master.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Falk throws 3 TDs, No. 19 Washington State beats Utah 33-25</strong><em class="description">Luke Falk threw for 311 yards and three touchdowns and No. 19 Washington State beat Utah 33-25 on Saturday.</em></div></a><a href="https://seattle.cbslocal.com/photo-galleries/2017/11/11/loves-3-tds-lead-stanford-past-no-9-washington-30-22/" title="Love&#039;s 3 TDs lead Stanford past No. 9 Washington 30-22" class="cbs-thumbnail-link item-1510412000 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2017/11/gettyimages-872711592_master.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Love&#039;s 3 TDs lead Stanford past No. 9 Washington 30-22</strong><em class="description">Love showed he had plenty left in the latest signature performance in his campaign for the Heisman Trophy.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link"><a href="http://seattle.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a></li><li class="menu-top-item item-3 w-link"><a href="https://seattle.cbslocal.com/live/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://seattle.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Headlines</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2020/05/22/quarantine-cooking-nonstick-cookware-guide/" title="Quarantine Cooking: Your Essential Nonstick Cookware Guide" class="cbs-thumbnail-link item-1590161120" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/nonstickpans.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Cooking: Your Essential Nonstick Cookware Guide</strong><em class="description">Step up your quarantine cooking with this guide to nonstick cookware.</em></div></a><a href="https://seattle.cbslocal.com/2020/05/22/how-to-6-easy-steps-to-make-homemade-soft-pretzels/" title="How To: 6 Easy Steps To Make Homemade Soft Pretzels" class="cbs-thumbnail-link item-1590161082" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/homemadepretzel.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How To: 6 Easy Steps To Make Homemade Soft Pretzels</strong><em class="description">Learn how to make your own homemade soft pretzels with these six easy steps!</em></div></a><a href="https://seattle.cbslocal.com/2020/05/15/recipes-vodka-in-vodka-sauce-why/" title="5 Vodka Sauce Recipes To Try This Week" class="cbs-thumbnail-link item-1589569648" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/chowhound111.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">5 Vodka Sauce Recipes To Try This Week</strong><em class="description">And would you miss it if it wasn&#039;t there?</em></div></a><a href="https://seattle.cbslocal.com/2020/05/15/best-make-ahead-freezer-meals/" title="Try These Make-Ahead Freezer Meals Perfect For Weeknights" class="cbs-thumbnail-link item-1589569416" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/freezerfood.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Try These Make-Ahead Freezer Meals Perfect For Weeknights</strong><em class="description">Set yourself up for easy weeknight dinners no matter what!</em></div></a><a href="https://seattle.cbslocal.com/2020/05/13/the-most-searched-recipe-in-every-state-during-quarantine-coronavirus/" title="Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine" class="cbs-thumbnail-link item-1589398031" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/QuarantineRecipesFeat.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine</strong><em class="description">Find the most popular eats for your home state and across the country during the coronavirus quarantine.</em></div></a><a href="https://seattle.cbslocal.com/2020/05/13/how-to-make-homemade-bagels-quarantine/" title="Quarantine Recipes: How To Make Homemade Bagels" class="cbs-thumbnail-link item-1589397541" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/bagelfeat.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Recipes: How To Make Homemade Bagels</strong><em class="description">See how to make your own homemade bagels while stuck inside during quarantine.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link"><a href="http://cwseattle.cbslocal.com/" title="CW 11" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CW 11</strong></div></a></li><li class="menu-top-item item-6 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">More</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-5 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://seattle.cbslocal.com/category/travel/">Travel</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/08/GettyImages-466663843-17.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://seattle.cbslocal.com/2019/06/13/top-3-eco-friendly-vacation-spots/" title="Top 3 Eco-Friendly Vacation Spots" class="cbs-thumbnail-link item-1560449704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/06/gettyimages-598645380-e1537896793352.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 3 Eco-Friendly Vacation Spots</strong><em class="description">Check out the three best spots for an eco-friendly vacation!</em></div></a><a href="https://seattle.cbslocal.com/2019/04/04/final-four-guide-top-10-instagram-worthy-spots-in-minneapolis/" title="Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis" class="cbs-thumbnail-link item-1554411634" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/04/igworthy.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis</strong><em class="description">With thousands of Final Four fans heading to downtown Minneapolis in the coming days, you better believe the Instagram filters will be flying.</em></div></a><a href="https://seattle.cbslocal.com/2019/04/04/final-four-guide-best-breweries-minneapolis/" title="Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis" class="cbs-thumbnail-link item-1554411465" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/04/187774436.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis</strong><em class="description">Beer-lovers visiting Minneapolis for the Final Four won’t have to go far to find Minnesota’s most beloved beers. Walk in any direction out of U.S. Bank Stadium and you’ll probably find a bar or restaurant serving craft beers from the Twin Cities, the North Shore and other parts of “The Land of 10,000 Beers.&quot; But for hop heads seeking a more direct experience of the state’s brewing culture, there are a few places that need to be on your radar, because they’re well worth the Lyft ride.</em></div></a><a href="https://seattle.cbslocal.com/2019/04/04/final-four-guide-5-restaurants-near-u-s-bank-stadium/" title="Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium" class="cbs-thumbnail-link item-1554410992" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/04/107277389-e1538670804895.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium</strong><em class="description">In Minneapolis for the Final Four and want to try the restaurants where Minneapolitans love to eat? Look no further. Below are some of the most beloved spots in the City of Lakes within walking distance, or a short Lyft ride, from U.S. Bank Stadium.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/category/only-cbs/" title="CBS Entertainment" class="cbs-thumbnail-link item-1519667323" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/02/onlycbs.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Entertainment</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	
	
	<div id="info-search"><form action="https://seattle.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">#8 Florida Vs #5 Georgia: With Strong Game Saturday, &#8216;Kyle Trask Will Be Talked About In Heisman Trophy Race,&#8217; Says CBS&#8217; Rick Neuheisel</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">November 5, 2020 at 12:38 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://seattle.cbslocal.com/tag/college-football/">College Football</a>, <a href="https://seattle.cbslocal.com/tag/ryan-mayer/">Ryan Mayer</a>, <a href="https://seattle.cbslocal.com/tag/sec-on-cbs/">SEC on CBS</a></div></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-sendtonews  close-btn" id="featured-media"><div class="s2nPlayer k-3R9v8NCqMX-1026318-5588" data-type="float"></div><script src="https://embed.sendtonews.com/player3/embedcode.js?SC=3R9v8NCqMX-1026318-5588&sound=on&floatwidth=430&offsetx=15&offsety=80&floatposition=bottom-right" data-type="s2nScript"></script></section>
<div class="main-story-wrapper"><p><strong>(<a href="https://miami.cbslocal.com/2020/11/05/florida-georgia-football-2020-rick-neuheisel-cbs/" target="_blank" rel="noopener noreferrer">CBS Miami</a>)- </strong>This Saturday sees the renewal of the game dubbed &#8220;The World&#8217;s Largest Outdoor Cocktail Party&#8221; when #8 Florida meets #5 Georgia at TIAA Bank Field in Jacksonville, Florida. As usual, the game is getting the SEC Game of the Week treatment on CBS with Brad Nessler, Gary Danielson and Jamie Erdahl on the call with kickoff set for 3:30 p.m. Eastern Time on CBS.</p>
<p>This year&#8217;s game, as with the past few years now, is likely to decide the winner of the SEC East division. In each of the last three seasons, it has been Kirby Smart and the Georgia Bulldogs taking the win and the</p>
<div id="attachment_61310" style="width: 222px" class="wp-caption alignright"><a href="https://sports.cbslocal.com/wp-content/uploads/sites/33383831/2020/11/GettyImages-1197043856.jpg"><img aria-describedby="caption-attachment-61310" loading="lazy" class="size-medium wp-image-61310" src="https://sports.cbslocal.com/wp-content/uploads/sites/33383831/2020/11/GettyImages-1197043856.jpg?w=212" alt="Georgia Head Coach Kirby Smart" width="212" height="300"></a><p id="caption-attachment-61310" class="wp-caption-text">Credit: Marianna Massey/Getty Images</p></div>
<p>division. This time around, Dan Mullen&#8217;s crew is hoping to change that. As CBS Sports college football analyst Rick Neuheisel puts it, for Kirby Smart, it&#8217;s a matter of maintaining course while Mullen and his staff have to cut down on some of the mistakes that cost them last year.</p>
<p>&#8220;Whatever Kirby Smart has been doing since taking over at Georgia in this game needs to continue to be what he does because he&#8217;s been brilliant. Dan Mullen? Not so much,&#8221; said Neuheisel. &#8220;And, I go back to a year ago where there was confusion on the sidelines whether it was he and his assistants, who was going into the game, they couldn&#8217;t get lined up, having to use timeouts, taking illegal procedure calls. Those things can&#8217;t happen in a game of this magnitude. It needs to settle down. It needs to be calm. And, when you start thinking about what&#8217;s at stake, sometimes the emotional side of things makes that very difficult to achieve. Calm is the order of the day.&#8221;</p>
<div id="attachment_61308" style="width: 210px" class="wp-caption alignleft"><a href="https://sports.cbslocal.com/wp-content/uploads/sites/33383831/2020/11/GettyImages-1179907646.jpg"><img aria-describedby="caption-attachment-61308" loading="lazy" class="size-medium wp-image-61308" src="https://sports.cbslocal.com/wp-content/uploads/sites/33383831/2020/11/GettyImages-1179907646.jpg?w=200" alt="Florida Gators QB Kyle Trask" width="200" height="300"></a><p id="caption-attachment-61308" class="wp-caption-text">Credit: David Rosenblum/Icon Sportswire via Getty Images</p></div>
<p>Calm is one thing that Florida senior quarterback Kyle Trask has seemed to be this season. Through four games, he&#8217;s thrown for over 1,300 yards with 18 touchdowns and just two interceptions while completing 68.3 percent of his passes. The Florida passing game has been one of the country&#8217;s best this season, ranking seventh in yards per game at 342.8. But, he&#8217;s going up against a Bulldogs defense that has been one of the better units against the pass this year, allowing 215 yards or fewer to every opponent except for Alabama.</p>
<p>However, there are a couple of key injuries on the back end that has Neuheisel giving the edge to the Florida offense in this matchup.</p>
<p>&#8220;I&#8217;m of the mind that this at least initially was going to favor Georgia. But, my concern now is you&#8217;ve got (Richard) LeCounte out. He had that car accident. You&#8217;ve got (Louis) Cine out. He was injured earlier. Those guys are going to be missed. And you&#8217;ve also seen an explosion of Florida offense with the development of Kyle Trask and what his development level is. Trask is 18 touchdown passes in only four games, those are Joe Burrow numbers,&#8221; said Neuheisel.</p>
<p>The numbers have been impressive and, if they continue this week, Neuheisel says that the Florida senior will have to be in the Heisman conversation.</p>
<p><strong>More From CBS: </strong></p>
<ul>
<li><a href="https://sports.cbslocal.com/2020/11/03/fantasy-football-waiver-wire-week-9-damien-harris/" target="_blank" rel="noopener noreferrer">Fantasy Football Waiver Wire Week 9: Damien Harris Settling Into Lead Back Role For Patriots</a></li>
<li><a href="https://sports.cbslocal.com/2020/11/05/rowdy-gaines-international-swimming-league-michael-phelps/" target="_blank" rel="noopener noreferrer">Rowdy Gaines: &#8216;Team USA Swimming Has Been #1 In The World Since 1956, No Other Sport Can Claim That Excellence&#8217;</a></li>
<li><a href="https://sports.cbslocal.com/2020/11/05/nfl-week-9-nfc-north-picks-packers-bears-lions-vikings/" target="_blank" rel="noopener noreferrer">NFL Week 9 NFC North Picks: &#8220;I Do Not See This Current Bears Team Going Into Tennessee And Beating Them,&#8221; Says CBS Chicago&#8217;s Matt Zahn</a></li>
</ul>
<p>&#8220;If he can continue that against this Georgia defense, I think people are going to be talking about Kyle Trask in this Heisman Trophy race as much as they&#8217;re talking about Lawrence, Fields and Jones,&#8221; said Neuheisel.</p>
<p>Trask also benefits from having a likely first round pick in next year&#8217;s NFL Draft in tight end Kyle Pitts. The junior has hauled in 22 catches this year for 355 yards and seven touchdowns already. Calling him a &#8220;unique&#8221; athlete, Neuheisel praises Pitts for his ability to affect the game both blocking and in the passing game.</p>
<p>&#8220;He can certainly handle his job on the end line as a run blocker and he can handle protections. They use him in such a</p>
<div id="attachment_61309" style="width: 248px" class="wp-caption alignright"><a href="https://sports.cbslocal.com/wp-content/uploads/sites/33383831/2020/11/GettyImages-1188060948.jpg"><img aria-describedby="caption-attachment-61309" loading="lazy" class="size-medium wp-image-61309" src="https://sports.cbslocal.com/wp-content/uploads/sites/33383831/2020/11/GettyImages-1188060948.jpg?w=238" alt="Florida Gators TE Kyle Pitts" width="238" height="300"></a><p id="caption-attachment-61309" class="wp-caption-text">Credit: Ed Zurga/Getty Images</p></div>
<p>way not only to get a run game going but also as a decoy when there&#8217;s so much coverage associated with him so they can go elsewhere with the ball. But, this guy&#8217;s ability to get open whether it be a safety, corner or linebacker is uncanny,&#8221; said Neuheisel. &#8220;Kyle Trask has the luxury of not worrying about the coverage, he can throw Pitts open. He can just throw it to a big body that has the athletic ability to contort and make plays whether it be back shoulder, in front of him, or over his head. We&#8217;ve seen him do all of that in just four games. The sample size is enough to know that this will be a Top 10 draft choice when the NFL reconvenes to do that portion of its schedule in April.&#8221;</p>
<p>On the other side of the ball, the Georgia offense has been pounding opponents with its running game as usual. The Bulldogs average 42 rushing attempts per game and 175 yards on those attempts (4.2 YPC). But, their passing game has been spotty the last two weeks under quarterback Stetson Bennett IV. A former walk-on, Neuheisel says he&#8217;s a fan of Bennett because he knows how hard it can be for a walk-on to become a starter. But, if the recent inconsistent play and turnovers aren&#8217;t cleaned up, he sees the advantage in Florida&#8217;s favor.</p>
<p>&#8220;This is the side of the ball, this matchup is going to determine the game,&#8221; said Neuheisel. &#8220;In the last six quarters, the second half against Alabama and then Kentucky, they have scored a grand total of 14 points. And they&#8217;ve had five turnovers. This has to change or it&#8217;s going to be a tough day at the office for Georgia.&#8221;</p>
<div id="attachment_61311" style="width: 238px" class="wp-caption alignleft"><a href="https://sports.cbslocal.com/wp-content/uploads/sites/33383831/2020/11/GettyImages-1283238184.jpg"><img aria-describedby="caption-attachment-61311" loading="lazy" class="size-medium wp-image-61311" src="https://sports.cbslocal.com/wp-content/uploads/sites/33383831/2020/11/GettyImages-1283238184.jpg?w=228" alt="Georgia QB Stetson Bennett IV" width="228" height="300"></a><p id="caption-attachment-61311" class="wp-caption-text">Credit: Andy Lyons/Getty Images</p></div>
<p>With a lean towards advantages for Florida on both the offensive and defensive sides of the ball, it would seem Neuheisel is leaning towards the Gators ending the Bulldogs losing streak. He says that it is, but there&#8217;s a key point to consider.</p>
<p>&#8220;My lean is that way but I say it with very much trepidation and here&#8217;s why. Because Georgia knows how to beat Florida. This group of Florida players does not know how to beat Georgia. Kyle Trask, given all that we said about him, is still a relatively young starter at quarterback,&#8221; said Neuheisel. &#8220;And, he is going to have to play a monster game in this spot and be above the ebbs and flows of momentum. He&#8217;s going to have to just put this team on his shoulder and say &#8216;Follow me, I&#8217;ll get you to a win.&#8217; If he does so, we&#8217;re going to be talking about Kyle Trask in a much different light than we are right now.&#8221;</p>
<p>The Bulldogs are <a href="https://www.sportsline.com/college-football/odds/" target="_blank" rel="noopener noreferrer">3.5 point favorites entering the day</a>. Kick off is set for 3:30 p.m. Eastern Time on CBS.</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/38f1iln"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/38f1iln"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/38f1iln"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CW11Seattle/" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/CW11Seattle/" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://seattle.cbslocal.com/2020/10/14/patients-living-with-an-incurable-blood-cancer-have-a-new-option/" title="Patients Living With An Incurable Blood Cancer Have A New Option" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/09/Sponsoredpic1REAL.jpg?resize=55%2C55&#038;ssl=1" alt="Patients Living With An Incurable Blood Cancer Have A New Option" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2020/10/14/patients-living-with-an-incurable-blood-cancer-have-a-new-option/" title="Patients Living With An Incurable Blood Cancer Have A New Option" class="bump-view" data-bump-view="tp">Patients Living With An Incurable Blood Cancer Have A New Option</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2020/10/19/stephen-colbert-2020-presidential-election-showtime-special/" title="Stephen Colbert To Host 2020 Election Night Special On Showtime" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/10/COLBERTELECTION_SRK_8938.R-e1603117242844-21.jpg?resize=55%2C55&#038;ssl=1" alt="Stephen Colbert To Host 2020 Election Night Special On Showtime" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2020/10/19/stephen-colbert-2020-presidential-election-showtime-special/" title="Stephen Colbert To Host 2020 Election Night Special On Showtime" class="bump-view" data-bump-view="tp">Stephen Colbert To Host 2020 Election Night Special On Showtime</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2014/08/27/7-professional-wrestlers-who-played-nfl-football/" title="7 Professional Wrestlers Who Played NFL Football" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2014/08/bill_goldberg.jpg?resize=55%2C55&#038;ssl=1" alt="7 Professional Wrestlers Who Played NFL Football" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2014/08/27/7-professional-wrestlers-who-played-nfl-football/" title="7 Professional Wrestlers Who Played NFL Football" class="bump-view" data-bump-view="tp">7 Professional Wrestlers Who Played NFL Football</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2020/05/15/recipes-vodka-in-vodka-sauce-why/" title="5 Vodka Sauce Recipes To Try This Week" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/chowhound111.jpg?resize=55%2C55&#038;ssl=1" alt="5 Vodka Sauce Recipes To Try This Week" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2020/05/15/recipes-vodka-in-vodka-sauce-why/" title="5 Vodka Sauce Recipes To Try This Week" class="bump-view" data-bump-view="tp">5 Vodka Sauce Recipes To Try This Week</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2020/05/28/teens-raise-11000-for-supplies-to-help-navajo-nation-during-coronavirus-pandemic/" title="Teens Raise $11,000 For Supplies To Help Navajo Nation During Coronavirus Pandemic" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/navajofundraiser.jpg?resize=55%2C55&#038;ssl=1" alt="Teens Raise $11,000 For Supplies To Help Navajo Nation During Coronavirus Pandemic" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2020/05/28/teens-raise-11000-for-supplies-to-help-navajo-nation-during-coronavirus-pandemic/" title="Teens Raise $11,000 For Supplies To Help Navajo Nation During Coronavirus Pandemic" class="bump-view" data-bump-view="tp">Teens Raise $11,000 For Supplies To Help Navajo Nation During Coronavirus Pandemic</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2020/10/21/phil-keoghan-the-amazing-race-season-32-deangelo-williams-gary-barnidge/" title="&#039;The Amazing Race&#039;s Phil Keoghan On What To Expect As A Contestant: &#039;You Just Never Know What You&#039;re Going To Do&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/10/113957_06769-10.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;The Amazing Race&#039;s Phil Keoghan On What To Expect As A Contestant: &#039;You Just Never Know What You&#039;re Going To Do&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2020/10/21/phil-keoghan-the-amazing-race-season-32-deangelo-williams-gary-barnidge/" title="&#039;The Amazing Race&#039;s Phil Keoghan On What To Expect As A Contestant: &#039;You Just Never Know What You&#039;re Going To Do&#039;" class="bump-view" data-bump-view="tp">&#039;The Amazing Race&#039;s Phil Keoghan On What To Expect As A Contestant: &#039;You Just Never Know What You&#039;re Going To Do&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2020/10/28/the-talk-sheryl-underwood-sharon-osbourne-eve-carrie-ann-inaba/" title="Grab Your Golden Ticket Today To Visit &#039;The Talk-olate Factory&#039; This Friday On CBS" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/10/thetalkfeat.jpg?resize=55%2C55&#038;ssl=1" alt="Grab Your Golden Ticket Today To Visit &#039;The Talk-olate Factory&#039; This Friday On CBS" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2020/10/28/the-talk-sheryl-underwood-sharon-osbourne-eve-carrie-ann-inaba/" title="Grab Your Golden Ticket Today To Visit &#039;The Talk-olate Factory&#039; This Friday On CBS" class="bump-view" data-bump-view="tp">Grab Your Golden Ticket Today To Visit &#039;The Talk-olate Factory&#039; This Friday On CBS</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2020/10/28/nfl-week-8-afc-north-picks-steelers-ravens-browns-bengals/" title="NFL Week 8 AFC North Picks: &#039;When The Steelers Play The Ravens, Somebody Wins By Three Points,&#039; Says SportsLine&#039;s Kenny White" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/10/ben-roethlisberger-steelers-1.jpg?resize=55%2C55&#038;ssl=1" alt="NFL Week 8 AFC North Picks: &#039;When The Steelers Play The Ravens, Somebody Wins By Three Points,&#039; Says SportsLine&#039;s Kenny White" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2020/10/28/nfl-week-8-afc-north-picks-steelers-ravens-browns-bengals/" title="NFL Week 8 AFC North Picks: &#039;When The Steelers Play The Ravens, Somebody Wins By Three Points,&#039; Says SportsLine&#039;s Kenny White" class="bump-view" data-bump-view="tp">NFL Week 8 AFC North Picks: &#039;When The Steelers Play The Ravens, Somebody Wins By Three Points,&#039; Says SportsLine&#039;s Kenny White</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2020/10/27/drew-barrymore-the-drew-barrymore-show/" title="Drew Barrymore: &#039;My Goal With The Show Is To Feel Like We&#039;re All In On Something Together&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/10/GettyImages-1272633654-e1603800838834.jpg?resize=55%2C55&#038;ssl=1" alt="Drew Barrymore: &#039;My Goal With The Show Is To Feel Like We&#039;re All In On Something Together&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2020/10/27/drew-barrymore-the-drew-barrymore-show/" title="Drew Barrymore: &#039;My Goal With The Show Is To Feel Like We&#039;re All In On Something Together&#039;" class="bump-view" data-bump-view="tp">Drew Barrymore: &#039;My Goal With The Show Is To Feel Like We&#039;re All In On Something Together&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2020/07/29/covid-19-coronavirus-phone-clean-protection/" title="The Forgotten Fight Against COVID-19: Are You Protecting Your Phone?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/07/AERIS-edited-lifestyle-06222020-6.jpg?resize=55%2C55&#038;ssl=1" alt="The Forgotten Fight Against COVID-19: Are You Protecting Your Phone?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2020/07/29/covid-19-coronavirus-phone-clean-protection/" title="The Forgotten Fight Against COVID-19: Are You Protecting Your Phone?" class="bump-view" data-bump-view="tp">The Forgotten Fight Against COVID-19: Are You Protecting Your Phone?</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
										<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CW11Seattle/" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/CW11Seattle/" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">Entertainment</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="https://seattle.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://seattle.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/about-us/" title="About Us" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">About Us</strong></div></a><a href="http://seattle.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://seattle.cbslocal.com" class="logo"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Seattle" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2020 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=seattle.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-50590" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50590"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-50591" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50591"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-245005" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245005"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-245006" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245006"><a href="https://ca.privacy.cbs/donotsell">Do Not Sell My Information</a></li>
<li id="menu-item-175000" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-175000"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='all-css-0' href='https://seattle.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1563381301g' type='text/css' media='all' />
<script id='jetpack-facebook-embed-js-extra'>
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
</script>
<script type='text/javascript' src='https://seattle.cbslocal.com/_static/??-eJyVjUEOwjAMBD+E46AWJA6Ip6AmMchp7ETEUb9PufXKcaWZWdwaxKpGaigDWhlv1o6ZrC1xhZvz+GSNGAaXhK8lUqh1BZJAyQmry/2EfzVsYzP6gLFQYaVjZafKSLS7/TePLw+5n69+9n6a5kv+AvMJQRA='></script>
<script type='text/javascript' src='https://stats.wp.com/e-202045.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.0.2.1',blog:'162246008',post:'249917',tz:'-8',srv:'seattle.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246008', '249917' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>