<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://seattle.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="champions league, uefa champions league, champions league final, champions league cbs," />
<meta name="keywords" content="champions league, uefa champions league, champions league final, champions league cbs," />
<meta property="fb:pages" content="312016212245379" />
<title>UEFA Champions League Final: How To Watch, Coverage Plan For Chelsea Vs. Manchester City &#8211; CBS Seattle</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="CBS Seattle &raquo; Feed" href="https://seattle.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://seattle.cbslocal.com/_static/??-eJytj0kOwjAMRS9EMC1i2CDOksGUqI4dZRDXJ6RsWEElVra//b6+4RGVFS7IBcodA2awJisSqwk8W6ruJeUMN5GCadvaDfwEYTDoFjYmJNHuOxypTp4zBHGV2ka/DVpdD/cDFTTrCVO3+VBUCzkXiSteWjxqMKw9KfI8/z8VUpu49H+v4TIch9N5POzH3RN1jZ9U' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://seattle.cbslocal.com/_static/??-eJyNy8EJgDAMQNGFrCGooAdxlhqDCmksJCJur11AvH7ehysHOtRZHXzjxAY0W5CDooD5LVyTWQVfbFeScynJDHJcOTinLNF/vGVheaO6FT2lEbsBEdu+wQchtzkW' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://seattle.cbslocal.com/_static/??-eJydUllSwzAMvRCuW+gU+GA4i+KI1ES2PLbSkNsjd6EDGZbwp+0tkm3HZBxHwShW9hiwWNcUQ+yAbKKh87HYwO1A2jkOmAAROszWFa1MCbcrjW7sT0Q+OhraWlLM6Fs0giERCJaF4ARZ/oD56rzsOYvjC8s1XSCPocH2hD+GhnwR40CAuFu4hm7hHaE5XI/3qd8qtW0U2KtKkyFPtshEuAo+Lt9eL96hfFy/xjOSMJgL7BUlgSo/ru5nFC/gsGGutnoN3s62Fluaf6UAua8Kp3nHxPkfD/0bLx8wj9nL3PI3B6gU57xCnsPTZne7ftht13ebdyqqNsQ=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://seattle.cbslocal.com/_static/??-eJy1UEEOwjAM+xBdxkATF8RbSpeNljQtSwva7ykTB3YbSJysOLZjBR5RmcAJOUG6oEcBcxZFwWgCy4ZyVygnEANNvSWqvOXKyQbWGt0qR6Q8WBbwoctUNrqbzQXUvflMWETfMo7TG1aJlLfDqBP+1GkWKK9ZDzi+oheEKveuKcSvntNnNskGln8UQioTJym5J3/ctk19aPf1rnFPsLq6Mg=='></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.7.2' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://seattle.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILYoACQ6Ib+naqEuVphNp2e+vQlx22W6W/WzDugy+aCWtUGfKZOAnG6R4J8DqpYVuJQMXZjL+0phZx2QXOCp2PkqZnJySu4tPZS902lmkRVaDXEKTnqwcItXfxF/2iXd+4f2JiLfHFdMGCqhUzA=='></script>
<link rel="https://api.w.org/" href="https://seattle.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://seattle.cbslocal.com/wp-json/wp/v2/posts/255390" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://seattle.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://seattle.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://cbsloc.al/3oOz5bu' />
<link rel="alternate" type="application/json+oembed" href="https://seattle.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseattle.cbslocal.com%2F2021%2F05%2F25%2Fuefa-champions-league-final-cbs%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://seattle.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseattle.cbslocal.com%2F2021%2F05%2F25%2Fuefa-champions-league-final-cbs%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		
<meta property="og:title" content="UEFA Champions League Final: How To Watch, Coverage Plan For Chelsea Vs. Manchester City" /><meta property="og:image" content="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/GettyImages-1231802430.jpg?w=1500" /><meta property="og:image:secure_url" content="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/GettyImages-1231802430.jpg?w=1500" /><meta property="og:image:width" content="1500" /><meta property="og:image:height" content="1000" /><meta property="og:description" content="The all England final featuring Chelsea and Manchester City is getting wall-to-wall coverage on CBS and various platforms. 📺📺📺" /><meta property="og:type" content="article" /><meta property="og:url" content="https://seattle.cbslocal.com/2021/05/25/uefa-champions-league-final-cbs/" /><meta property="article:published_time" content="2021-05-25T10:47:35+00:00" /><meta property="article:suggested-social-copy" content="The all England final featuring Chelsea and Manchester City is getting wall-to-wall coverage on CBS and various platforms. 📺📺📺" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="CBS+" /><meta property="article:publisher" content="https://www.facebook.com/CW11Seattle/" /><meta property="article:author" content="https://www.facebook.com/CW11Seattle/" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/GettyImages-1231802430.jpg?w=1500"><meta name="twitter:title" content="UEFA Champions League Final: How To Watch, Coverage Plan For Chelsea Vs. Manchester City"/><meta name="twitter:description" content="The all England final featuring Chelsea and Manchester City is getting wall-to-wall coverage on CBS and various platforms. 📺📺📺"/><meta name="twitter:site" content="/CW11Seattle/"/>
<link rel="canonical" href="https://philadelphia.cbslocal.com/2021/05/25/uefa-champions-league-final-cbs/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://seattle.cbslocal.com/2021/05/25/uefa-champions-league-final-cbs/?amp">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/seattle.cbslocal.com","url":"https:\/\/seattle.cbslocal.com","name":"CBS Seattle","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/seattle.cbslocal.com\/wp-content\/uploads\/sites\/15909838\/2018\/06\/2_cbs_seattle.png?w=209"}},"url":"https:\/\/seattle.cbslocal.com\/2021\/05\/25\/uefa-champions-league-final-cbs\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/seattle.cbslocal.com\/2021\/05\/25\/uefa-champions-league-final-cbs\/"},"headline":"UEFA Champions League Final: How To Watch, Coverage Plan For Chelsea Vs. Manchester City","description":"The all England final featuring Chelsea and Manchester City is getting wall-to-wall coverage on CBS and various platforms. \ud83d\udcfa\ud83d\udcfa\ud83d\udcfa","image":"https:\/\/seattle.cbslocal.com\/wp-content\/uploads\/sites\/15909838\/2021\/05\/GettyImages-1231802430.jpg?w=1500","keywords":["CBS+","Ryan Mayer","UEFA Champions League","UEFA Champions League Final: How To Watch, Coverage Plan For Chelsea Vs. Manchester City"],"datePublished":"2021-05-25T10:47:35+00:00","dateModified":"2021-05-25T10:47:35+00:00"}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.SEATTLE","default",["uefachampionsleaguefinalhowtowatchcoverageplanforchelseavsmanchestercity","post","article","cbs","ryanmayer","uefachampionsleague","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("3");</script>
		<style type="text/css" id="wp-custom-css">
			
.single-post sup {
	vertical-align: super;
	font-size: 10px;
}

.postid-244620  .partner-container{
	display: none;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="The all England final featuring Chelsea and Manchester City is getting wall-to-wall coverage on CBS and various platforms. 📺📺📺" />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-255390 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://seattle.cbslocal.com" id="header-logo"><img src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/06/2_cbs_seattle.png?w=209" alt="CBS Seattle" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="http://seattle.cbslocal.com/live" title="Live Videos" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Live Videos</strong></div></a><a href="http://seattle.cbslocal.com/photo-galleries/" title="Galleries" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Galleries</strong></div></a><a href="http://seattle.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="http://seattle.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Best Of</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2020/05/22/quarantine-cooking-nonstick-cookware-guide/" title="Quarantine Cooking: Your Essential Nonstick Cookware Guide" class="cbs-thumbnail-link item-1590161120" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/nonstickpans.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Cooking: Your Essential Nonstick Cookware Guide</strong><em class="description">Step up your quarantine cooking with this guide to nonstick cookware.</em></div></a><a href="https://seattle.cbslocal.com/2020/05/22/how-to-6-easy-steps-to-make-homemade-soft-pretzels/" title="How To: 6 Easy Steps To Make Homemade Soft Pretzels" class="cbs-thumbnail-link item-1590161082" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/homemadepretzel.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How To: 6 Easy Steps To Make Homemade Soft Pretzels</strong><em class="description">Learn how to make your own homemade soft pretzels with these six easy steps!</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Travel</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/08/GettyImages-466663843-17.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://seattle.cbslocal.com/2019/06/13/top-3-eco-friendly-vacation-spots/" title="Top 3 Eco-Friendly Vacation Spots" class="cbs-thumbnail-link item-1560449704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/06/gettyimages-598645380-e1537896793352.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 3 Eco-Friendly Vacation Spots</strong><em class="description">Check out the three best spots for an eco-friendly vacation!</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">CBS Entertainment</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-1519667323" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/02/CBS.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS+</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="http://seattle.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://www.cbssports.com/college-football/" title="NCAAF" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">NCAAF</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2021/05/25/colonial-country-club-profile-hogans-alley-horrible-horseshoe-charles-schwab-challenge/" title="Colonial Country Club: Profile Of Hogan&#039;s Alley, Home Of The Horrible Horseshoe" class="cbs-thumbnail-link item-1621976931" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/06/charles-schwab-challenge-colonial-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Colonial Country Club: Profile Of Hogan&#039;s Alley, Home Of The Horrible Horseshoe</strong><em class="description">One of the PGA Tour&#039;s classic venues, Colonial Country Club welcomes the Charles Schwab Challenge to Fort Worth.</em></div></a><a href="https://seattle.cbslocal.com/2021/05/25/baseball-report-angels-mike-trout-padres/" title="Baseball Report: Can Angels Survive Without Trout?" class="cbs-thumbnail-link item-1621976617" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/los-angeles-angels-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Baseball Report: Can Angels Survive Without Trout?</strong><em class="description">This week&#039;s baseball report looks at the Los Angeles Angels without Trout, the San Diego Padres&#039; impressive homestand, and Juan Soto&#039;s gaffe that could have been much worse.</em></div></a><a href="https://seattle.cbslocal.com/2021/05/20/pga-championship-preview-ocean-course-kiawah-island-rory-mcilroy/" title="PGA Championship Preview: &#039;It&#039;s The Toughest Wind In Golf,&#039; Says Nick Faldo About Ocean Course At Kiawah Island" class="cbs-thumbnail-link item-1621528202" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/collin-morikawa-pga-championship-2020-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">PGA Championship Preview: &#039;It&#039;s The Toughest Wind In Golf,&#039; Says Nick Faldo About Ocean Course At Kiawah Island</strong><em class="description">The PGA Championship, set for the Ocean Course At Kiawah Island, brings together the PGA Tour&#039;s top talent on a course that will challenge them.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Galleries</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/photo-galleries/2021/01/26/remembering-hank-aaron/" title="Remembering Hank Aaron" class="cbs-thumbnail-link item-1611694661 content-type-photo" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Remembering Hank Aaron</strong></div></a><a href="https://seattle.cbslocal.com/photo-galleries/2017/11/12/falk-throws-3-tds-no-19-washington-state-beats-utah-33-25/" title="Falk throws 3 TDs, No. 19 Washington State beats Utah 33-25" class="cbs-thumbnail-link item-1510499358 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2017/11/gettyimages-873591258_master.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Falk throws 3 TDs, No. 19 Washington State beats Utah 33-25</strong><em class="description">Luke Falk threw for 311 yards and three touchdowns and No. 19 Washington State beat Utah 33-25 on Saturday.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link"><a href="http://seattle.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a></li><li class="menu-top-item item-3 w-link"><a href="https://seattle.cbslocal.com/live/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://seattle.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CBS+</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Headlines</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2021/05/25/uefa-champions-league-final-cbs/" title="UEFA Champions League Final: How To Watch, Coverage Plan For Chelsea Vs. Manchester City" class="cbs-thumbnail-link item-1621964855" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/GettyImages-1231802430.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">UEFA Champions League Final: How To Watch, Coverage Plan For Chelsea Vs. Manchester City</strong><em class="description">The all England final featuring Chelsea and Manchester City is getting wall-to-wall coverage on CBS and various platforms. 📺📺📺</em></div></a><a href="https://seattle.cbslocal.com/2021/05/24/andrew-rannells-black-monday-showtime-interview/" title="WATCH: Andrew Rannells On Season 3 Of Showtime&#039;s &#039;Black Monday&#039; &amp; Playing Blair Pfaff" class="cbs-thumbnail-link item-1621875616" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/BlackMonday_302_1573_R-e1621264827261.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">WATCH: Andrew Rannells On Season 3 Of Showtime&#039;s &#039;Black Monday&#039; &amp; Playing Blair Pfaff</strong><em class="description">The star of &quot;Black Monday&quot; discusses season three and discusses what it is like to work with Don Cheadle. 💸💸💸</em></div></a><a href="https://seattle.cbslocal.com/2021/05/24/stephen-colbert-ed-sullivan-theater-june-14/" title="&#039;The Late Show With Stephen Colbert&#039; Returns To Ed Sullivan Theater With Fully Vaccinated Audience June 14" class="cbs-thumbnail-link item-1621871862" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/107490_D0216bc-e1621871269309.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;The Late Show With Stephen Colbert&#039; Returns To Ed Sullivan Theater With Fully Vaccinated Audience June 14</strong><em class="description">Stephen Colbert is returning to the iconic Ed Sullivan Theater with a full audience on June 14. 🎉🎉🎉</em></div></a><a href="https://seattle.cbslocal.com/2021/05/24/casey-wilson-paul-scheer-black-monday-interview/" title="&#039;Don Cheadle Is A True Actor In Every Sense Of The Word&#039;: Casey Wilson &amp; Paul Scheer Preview Season 3 Of Showtime&#039;s &#039;Black Monday&#039;" class="cbs-thumbnail-link item-1621868437" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/black-monday.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;Don Cheadle Is A True Actor In Every Sense Of The Word&#039;: Casey Wilson &amp; Paul Scheer Preview Season 3 Of Showtime&#039;s &#039;Black Monday&#039;</strong><em class="description">Need a new TV show to watch? Casey Wilson and Paul Scheer make the pitch for why it should be Black Monday. 📺</em></div></a><a href="https://seattle.cbslocal.com/2021/05/24/robert-king-michelle-king-the-bite/" title="WATCH: Robert &amp; Michelle King On &#039;The Bite,&#039; &#039;The Good Fight&#039; &amp; &#039;Evil&#039;" class="cbs-thumbnail-link item-1621864801" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/GettyImages-521949344-e1621622823459.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">WATCH: Robert &amp; Michelle King On &#039;The Bite,&#039; &#039;The Good Fight&#039; &amp; &#039;Evil&#039;</strong><em class="description">The husband &amp; wife discuss their new show starring Taylor Schilling and how they&#039;ve created several successful TV shows from &quot;The Good Fight&quot; to Evil.&quot; 📺</em></div></a><a href="https://seattle.cbslocal.com/2021/05/24/jacob-latimore-the-chi-showtime-interview/" title="&#039;You Will See A Different Dynamic From Emmett This Year&#039;: Jacob Latimore On Season 4 Of Showtime&#039;s &#039;The Chi&#039;" class="cbs-thumbnail-link item-1621861246" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/TheChi_401_0552_R.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;You Will See A Different Dynamic From Emmett This Year&#039;: Jacob Latimore On Season 4 Of Showtime&#039;s &#039;The Chi&#039;</strong><em class="description">The star of &quot;The Chi&quot; on Showtime previews what fans can expect in season four of the hit series from Lena Waithe.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link"><a href="http://cwseattle.cbslocal.com/" title="CW 11" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CW 11</strong></div></a></li><li class="menu-top-item item-6 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">More</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-5 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://seattle.cbslocal.com/category/travel/">Travel</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://seattle.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/08/GettyImages-466663843-17.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://seattle.cbslocal.com/2019/06/13/top-3-eco-friendly-vacation-spots/" title="Top 3 Eco-Friendly Vacation Spots" class="cbs-thumbnail-link item-1560449704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/06/gettyimages-598645380-e1537896793352.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 3 Eco-Friendly Vacation Spots</strong><em class="description">Check out the three best spots for an eco-friendly vacation!</em></div></a><a href="https://seattle.cbslocal.com/2019/04/04/final-four-guide-top-10-instagram-worthy-spots-in-minneapolis/" title="Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis" class="cbs-thumbnail-link item-1554411634" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/04/igworthy.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis</strong><em class="description">With thousands of Final Four fans heading to downtown Minneapolis in the coming days, you better believe the Instagram filters will be flying.</em></div></a><a href="https://seattle.cbslocal.com/2019/04/04/final-four-guide-best-breweries-minneapolis/" title="Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis" class="cbs-thumbnail-link item-1554411465" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/04/187774436.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis</strong><em class="description">Beer-lovers visiting Minneapolis for the Final Four won’t have to go far to find Minnesota’s most beloved beers. Walk in any direction out of U.S. Bank Stadium and you’ll probably find a bar or restaurant serving craft beers from the Twin Cities, the North Shore and other parts of “The Land of 10,000 Beers.&quot; But for hop heads seeking a more direct experience of the state’s brewing culture, there are a few places that need to be on your radar, because they’re well worth the Lyft ride.</em></div></a><a href="https://seattle.cbslocal.com/2019/04/04/final-four-guide-5-restaurants-near-u-s-bank-stadium/" title="Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium" class="cbs-thumbnail-link item-1554410992" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/04/107277389-e1538670804895.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium</strong><em class="description">In Minneapolis for the Final Four and want to try the restaurants where Minneapolitans love to eat? Look no further. Below are some of the most beloved spots in the City of Lakes within walking distance, or a short Lyft ride, from U.S. Bank Stadium.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-1519667323" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/02/CBS.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS+</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	
	
	<div id="info-search"><form action="https://seattle.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size='[[970,250],[970,66],[728,90]]' data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">UEFA Champions League Final: How To Watch, Coverage Plan For Chelsea Vs. Manchester City</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">May 25, 2021 at 10:47 am</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://seattle.cbslocal.com/tag/ryan-mayer/">Ryan Mayer</a>, <a href="https://seattle.cbslocal.com/tag/uefa-champions-league/">UEFA Champions League</a></div></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-sendtonews  close-btn" id="featured-media"><div class="s2nPlayer k-iUqw3YMgcY-1330408-5588" data-type="float"></div><script src="https://embed.sendtonews.com/player3/embedcode.js?SC=iUqw3YMgcY-1330408-5588&sound=on&floatwidth=430&offsetx=15&offsety=80&floatposition=bottom-right" data-type="s2nScript"></script></section>
<div class="main-story-wrapper"><p><strong>(CBS Local)- </strong>The biggest game in European soccer kicks off this Saturday with CBS bringing viewers wall-to-wall coverage of the 2020-21 UEFA Champions League Final between Chelsea and Manchester City. All coverage of the final will air on CBS Television Network and stream via Paramount+</p>
<p>Coverage of the all England final begins at 12:30 p.m. Eastern Time with a soccer-themed edition of We Need To Talk with Tina Cervasio, Sarah Kustok, Aly Wagner and Jules Breach.</p>
<p>Then, at 1:30 p.m. Eastern Time the network presents UEFA Champions League Today, featuring host Kate Abdo with analysts Micah Richards, Jamie Carragher, and Roberto Martinez in studio. They will be joined by reporters Peter Schmeichel, Guillem Balague, Nico Cantor and Jenny Chiu who will be on the ground in Portugal at Est&aacute;dio do Drag&atilde;o.</p>
<blockquote class="twitter-tweet" data-width="420" data-dnt="true">
<p lang="en" dir="ltr">This week a new European Champion will be crowned. ⚔️</p>
<p>CANNOT WAIT. 🍿 <a href="https://t.co/3P30K04ijf">pic.twitter.com/3P30K04ijf</a></p>
<p>&mdash; Champions League on CBS Sports (@UCLonCBSSports) <a href="https://twitter.com/UCLonCBSSports/status/1396811118178455557?ref_src=twsrc%5Etfw">May 24, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>The pre-game show will be followed by the UEFA Champions League Pepsi Kickoff show at 2:40 p.m. featuring a performance from DJ and producer Marshmello in the lead up to kick off at 3 p.m.</p>
<p>For CBS, it marks the end of the first year of the network&#8217;s Champions League coverage and, in the lead up to Saturday&#8217;s broadcast, there has been time to reflect on the first year of coverage.</p>
<p>&#8220;It&#8217;s the highlight of my career. I&#8217;ve been blessed in 20 years to have worked on Super Bowls, the Masters, the Olympics, NBA Finals, virtually every big sporting event you can think of. The one sport I never worked on was this one. And it turned out this was the one sport that I grew up with,&#8221; Pete Radovich, Coordinating Producer for CBS Sports said on a media call. &#8220;All of those things that I&#8217;ve worked on I&#8217;ve been proud of. But this has been the number one most rewarding thing I&#8217;ve worked on in my career.&#8221;</p>
<p><strong>UEFA Champions League Final</strong></p>
<p><strong>When: </strong>Saturday, May 29</p>
<p><strong>Time: </strong>3 p.m. ET</p>
<p><strong>How To Watch: </strong>CBS, streaming on <a href="https://www.paramountplus.com/" target="_blank" rel="nofollow">Paramount+</a></p>
<p>Radovich and the studio crew of Abdo, Richards, Carragher and Martinez have hit the ground running in Year 1 by blending analysis with fun and personality to produce a show that Richards said has been a delight to work on.</p>
<p>&#8220;Working with CBS has just been a breath of fresh air,&#8221; Richards said. &#8220;We can just be ourselves. It helps that we&#8217;ve got credibility of course. Jamie has won it. Peter has won it. Roberto of course has managed the number one team in the world. So we&#8217;ve got credibility there but we can all be ourselves&#8230;.Pete has allowed us to be ourselves as long as we get the football side correct.&#8221;</p>
<blockquote class="twitter-tweet" data-width="420" data-dnt="true">
<p lang="en" dir="ltr">🗣 IT&#39;S <a href="https://twitter.com/hashtag/UCL?src=hash&amp;ref_src=twsrc%5Etfw">#UCL</a> FINAL WEEK <a href="https://twitter.com/MicahRichards?ref_src=twsrc%5Etfw">@micahrichards</a> <a href="https://twitter.com/Carra23?ref_src=twsrc%5Etfw">@carra23</a> <a href="https://t.co/uOJaXhso7c">pic.twitter.com/uOJaXhso7c</a></p>
<p>&mdash; Champions League on CBS Sports (@UCLonCBSSports) <a href="https://twitter.com/UCLonCBSSports/status/1396828476888473603?ref_src=twsrc%5Etfw">May 24, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Schmeichel agreed with Richards while also pointing to the quality of the work being done behind the scenes of each broadcast that makes the difference.</p>
<p>&#8220;I think that&#8217;s the biggest difference. The team that actually produces this is so much bigger. And the quality of the people that work behind the scenes it does make people like us in front of the camera look a lot better,&#8221; Schmeichel said.</p>
<p>In addition to the traditional pre-game show, <a href="https://www.cbssports.com/live/" target="_blank" rel="noopener">CBS Sports HQ</a> will have two hours of coverage pre-game and post-game. There will also be a second screen experience for fans on <a href="https://www.twitch.tv/cbssportshq" target="_blank" rel="nofollow">Twitch</a> with hosts Aaron West and Tosin Makinde.</p>
<p>The full schedule of coverage for Saturday&#8217;s UEFA Champions League final can be seen below. All times are Eastern.</p>
<table>
<tbody>
<tr>
<td>WE NEED TO TALK presented by Ford</td>
<td>12:30 PM &#8211; 1:30 PM</td>
<td>CBS / Paramount+</td>
</tr>
<tr>
<td>UEFA CHAMPIONS LEAGUE TODAY</p>
<p>presented by Lays</td>
<td>1:30 PM &#8211; 3:00 PM</td>
<td>CBS / Paramount+</td>
</tr>
<tr>
<td>UEFA CHAMPIONS LEAGUE PEPSI KICKOFF SHOW <em>*part of UEFA CHAMPIONS LEAGUE TODAY</em></td>
<td>2:40 PM &#8211; 3:00 PM</td>
<td>CBS / Paramount+</td>
</tr>
<tr>
<td>MANCHESTER CITY VS. CHELSEA</td>
<td>3:00 PM &#8211; 5:30 PM</td>
<td>CBS / Paramount+</td>
</tr>
<tr>
<td>UEFA CHAMPIONS LEAGUE POST-MATCH SHOW</td>
<td>5:30 PM &#8211; 6:30 PM</td>
<td>Paramount+ / CBS Sports Network</td>
</tr>
</tbody>
</table>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3oOz5bu"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3oOz5bu"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3oOz5bu"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size='[[1,5],"fluid"]' data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size='[[300,250],[300,600],[300,1050]]' data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CW11Seattle/" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/CW11Seattle/" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://seattle.cbslocal.com/2012/07/02/best-places-for-u-pick-cherries-in-wa/" title="Best Places for U-Pick Cherries in WA " class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2012/07/38120_144836508861914_232570_n.jpg?resize=55%2C55&#038;ssl=1" alt="Best Places for U-Pick Cherries in WA " data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2012/07/02/best-places-for-u-pick-cherries-in-wa/" title="Best Places for U-Pick Cherries in WA " class="bump-view" data-bump-view="tp">Best Places for U-Pick Cherries in WA </a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2021/05/05/summer-bbq-recipe-family-keto/" title="Low-Carb, High Flavor Summer Recipes For The Whole Family From &#039;Keto BBQ&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/KETOBBQFEAT.jpg?resize=55%2C55&#038;ssl=1" alt="Low-Carb, High Flavor Summer Recipes For The Whole Family From &#039;Keto BBQ&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2021/05/05/summer-bbq-recipe-family-keto/" title="Low-Carb, High Flavor Summer Recipes For The Whole Family From &#039;Keto BBQ&#039;" class="bump-view" data-bump-view="tp">Low-Carb, High Flavor Summer Recipes For The Whole Family From &#039;Keto BBQ&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2021/05/06/wells-fargo-championship-preview-quail-hollow-justin-thomas-jon-rahm-bryson-dechambeau/" title="Wells Fargo Championship Preview: &#039;Quail Hollow Tests You From The First Hole,&#039; Says CBS Sports&#039; Frank Nobilo" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/max-homa-wells-fargo-championship-1.jpg?resize=55%2C55&#038;ssl=1" alt="Wells Fargo Championship Preview: &#039;Quail Hollow Tests You From The First Hole,&#039; Says CBS Sports&#039; Frank Nobilo" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2021/05/06/wells-fargo-championship-preview-quail-hollow-justin-thomas-jon-rahm-bryson-dechambeau/" title="Wells Fargo Championship Preview: &#039;Quail Hollow Tests You From The First Hole,&#039; Says CBS Sports&#039; Frank Nobilo" class="bump-view" data-bump-view="tp">Wells Fargo Championship Preview: &#039;Quail Hollow Tests You From The First Hole,&#039; Says CBS Sports&#039; Frank Nobilo</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2020/07/01/coronavirus-summer-questions-kids-hiking-picnic-answers-dr-dave-hnida/" title="How Can I Safely BBQ With Friends, Family This Summer? Answers To Common Coronavirus Questions From Dr. Dave Hnida" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/07/americans-picnic-1.jpg?resize=55%2C55&#038;ssl=1" alt="How Can I Safely BBQ With Friends, Family This Summer? Answers To Common Coronavirus Questions From Dr. Dave Hnida" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2020/07/01/coronavirus-summer-questions-kids-hiking-picnic-answers-dr-dave-hnida/" title="How Can I Safely BBQ With Friends, Family This Summer? Answers To Common Coronavirus Questions From Dr. Dave Hnida" class="bump-view" data-bump-view="tp">How Can I Safely BBQ With Friends, Family This Summer? Answers To Common Coronavirus Questions From Dr. Dave Hnida</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2020/12/10/okee-dokee-brothers-grammy-nomination-best-childrens-album-all-white-nominees/" title="The Okee Dokee Brothers Decline Grammy Nomination For Best Children’s Album Due To &#039;All White&#039; Nominees" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/12/GettyImages-1156775147-2.jpg?resize=55%2C55&#038;ssl=1" alt="The Okee Dokee Brothers Decline Grammy Nomination For Best Children’s Album Due To &#039;All White&#039; Nominees" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2020/12/10/okee-dokee-brothers-grammy-nomination-best-childrens-album-all-white-nominees/" title="The Okee Dokee Brothers Decline Grammy Nomination For Best Children’s Album Due To &#039;All White&#039; Nominees" class="bump-view" data-bump-view="tp">The Okee Dokee Brothers Decline Grammy Nomination For Best Children’s Album Due To &#039;All White&#039; Nominees</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2020/12/09/covid-vaccine-availability-priority-healthcare-essential-workers/" title="When Can You Get The COVID Vaccine?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/12/covid-19-vaccine-1.jpg?resize=55%2C55&#038;ssl=1" alt="When Can You Get The COVID Vaccine?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2020/12/09/covid-vaccine-availability-priority-healthcare-essential-workers/" title="When Can You Get The COVID Vaccine?" class="bump-view" data-bump-view="tp">When Can You Get The COVID Vaccine?</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2021/05/12/drew-robinsons-solo-homer-another-chapter-in-minor-league-comeback/" title="Drew Robinson, Giants Prospect Who Lost Eye In Suicide Attempt, Smashes First Homer Since Comeback" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/DrewRobinson-1.jpg?resize=55%2C55&#038;ssl=1" alt="Drew Robinson, Giants Prospect Who Lost Eye In Suicide Attempt, Smashes First Homer Since Comeback" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2021/05/12/drew-robinsons-solo-homer-another-chapter-in-minor-league-comeback/" title="Drew Robinson, Giants Prospect Who Lost Eye In Suicide Attempt, Smashes First Homer Since Comeback" class="bump-view" data-bump-view="tp">Drew Robinson, Giants Prospect Who Lost Eye In Suicide Attempt, Smashes First Homer Since Comeback</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2020/07/29/covid-19-coronavirus-phone-clean-protection/" title="The Forgotten Fight Against COVID-19: Are You Protecting Your Phone?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/07/AERIS-edited-lifestyle-06222020-6.jpg?resize=55%2C55&#038;ssl=1" alt="The Forgotten Fight Against COVID-19: Are You Protecting Your Phone?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2020/07/29/covid-19-coronavirus-phone-clean-protection/" title="The Forgotten Fight Against COVID-19: Are You Protecting Your Phone?" class="bump-view" data-bump-view="tp">The Forgotten Fight Against COVID-19: Are You Protecting Your Phone?</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2021/05/10/molly-bernard-younger-paramount-plus-hilary-duff/" title="Molly Bernard On Paramount+&#039;s &#039;Younger&#039;: &#039;I Auditioned For A Six Line Guest Star And It Became A 7 Year Family&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/05/Younger_012821_705_NR_0098_R-e1620673633175.jpg?resize=55%2C55&#038;ssl=1" alt="Molly Bernard On Paramount+&#039;s &#039;Younger&#039;: &#039;I Auditioned For A Six Line Guest Star And It Became A 7 Year Family&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2021/05/10/molly-bernard-younger-paramount-plus-hilary-duff/" title="Molly Bernard On Paramount+&#039;s &#039;Younger&#039;: &#039;I Auditioned For A Six Line Guest Star And It Became A 7 Year Family&#039;" class="bump-view" data-bump-view="tp">Molly Bernard On Paramount+&#039;s &#039;Younger&#039;: &#039;I Auditioned For A Six Line Guest Star And It Became A 7 Year Family&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2021/04/29/kentucky-derby-horses-odds-predictions/" title="Kentucky Derby 2021 Preview: Essential Quality The Favorite, Can He Break A 60-Year Drought To Win From Post 14?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/04/GettyImages-1228376925.jpg?resize=55%2C55&#038;ssl=1" alt="Kentucky Derby 2021 Preview: Essential Quality The Favorite, Can He Break A 60-Year Drought To Win From Post 14?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2021/04/29/kentucky-derby-horses-odds-predictions/" title="Kentucky Derby 2021 Preview: Essential Quality The Favorite, Can He Break A 60-Year Drought To Win From Post 14?" class="bump-view" data-bump-view="tp">Kentucky Derby 2021 Preview: Essential Quality The Favorite, Can He Break A 60-Year Drought To Win From Post 14?</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size='[[300,250]]' data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size='[[728,90]]' data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
										<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CW11Seattle/" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/CW11Seattle/" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">Entertainment</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">CBS+</strong></div></a><a href="https://seattle.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://seattle.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://seattle.cbslocal.com/about-us/" title="About Us" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">About Us</strong></div></a><a href="http://seattle.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://seattle.cbslocal.com" class="logo"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-viacom-logo-white.png" alt="CBS Seattle" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2021 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=seattle.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-50590" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50590"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-50591" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50591"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-245005" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245005"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-245006" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245006"><a href="https://ca.privacy.cbs/donotsell">Do Not Sell My Personal Information</a></li>
<li id="menu-item-175000" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-175000"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size='[[1,8]]' data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size='[[1,6]]' data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size='[[1,7]]' data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='all-css-0' href='https://seattle.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1591114831g' type='text/css' media='all' />
<script id='jetpack-facebook-embed-js-extra'>
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
</script>
<script type='text/javascript' src='https://seattle.cbslocal.com/_static/??-eJyVjUEOwjAMBD+E41JQgQPiKahJDHIaOxFx1O9Tbr1yXGlmFtcKoaiRGkqHmvubtWEiq3NY4OYu+GQN6DvniK85kC9lARJP0QmrS+2AfzVsZTP6gLFQZqV9ZaNyj7S57Tf3Lw+5H6dxuE7n4TSmL/mfQSQ='></script>
<script src='https://stats.wp.com/e-202121.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.7',blog:'162246008',post:'255390',tz:'-7',srv:'seattle.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246008', '255390' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>