<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://seattle.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="roswell, new mexico, base, top, secret, the cw, nathan dean, jeanine mason" />
<meta name="keywords" content="roswell, new mexico, base, top, secret, the cw, nathan dean, jeanine mason" />
<meta property="fb:pages" content="312016212245379" />
<title>&#8216;Roswell, New Mexico&#8217; Stars Jeanine Mason And Nathan Dean Prepare For Season 3 On The CW: &#8216;This Season Is Wild&#8217; &#8211; CBS Seattle</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="CBS Seattle &raquo; Feed" href="https://seattle.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://seattle.cbslocal.com/_static/??-eJytj00OAiEMhS8kNrjAuDCehYE6kikt4Sdef5Bx40oncdX2td/LKzyTcsIVuUJ9YMQCbiqKxFmCwI6af0mlwF2kYj729gA/QRgn9BubMpJY/x1O1ObABaL4Rn1j3wa97ofHgYqW7Yx52HwoqodcqqQdL20eLU5sAykKvPw/FVKfuI5/b/GqzcmctdEXswJ1lZ9e' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://seattle.cbslocal.com/_static/??-eJyNy8EJgDAMQNGFrNEKxYs4S41BhTQtJCJur11AvH7eh6s4zGIkBrZTIgVc1HHGyKB2M7Wo2sAXOwT5XGtShRI3ckapcLQfb12I3yimVc9p6oMPYzf4wT8huzkV' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://seattle.cbslocal.com/_static/??-eJydkltywyAMRTdUTNJJk8lHp2uRQXVIBHhAjuvdV+TRJPW0tfsnIc6VdEH3rTIxMAbWvEOPWZs6K4oGSLfUNS5k7aPtSCqnC8pDgAaTNllOhhZXlURP+jchFwx1thwJ0zuLitG3BIx5JtxC4gnM98nzLiY28apyS2e0R1+jPfOnUJHLrAwwUGxmriFbOEOojjfzHupWpHUt4EG61AnSoDMPhJV3YUzsZVG0DpCkp/S+T8TlAZMibMAM03Cp3ecP0GTH5ZUb5K8XL/FIxHfqiu2RW5Btt9V2JPEOBusYixUHCT4uVsweafx9PaRD6XC+byLF9I/P9ZduPGLqk+PxyD8YUCQueUHe/Oty/bxZbBYvy/UndTZi6Q==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://seattle.cbslocal.com/_static/??-eJy1UEEOwjAM+xBd2SS2E+ItpctGS5qWJQXt95SJA7sNJE5WHNuxoh9J2UgCJFouEIC1PbPCaA1qRxZzXyjPOkWcB4dYBUeV553eavSbHAnz6Ih1iH3GsjH9Yi6g7s1nwir6lmGa37BJpIIbJyPwU6dFoIIhM8L0il4Rqty7SkxfPWfIZMVF4n8UAiwTCZfcUzjWbdPtu/2hbv0TsMK6NQ=='></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.7.2' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://seattle.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILSqHIg6Ib+nSqEuVthNJ2e+vQly4sJtlP9uwbxO2alQNbKVCCrjoJA2DAFeUHoeVFUJcSflNc+E6Z73Av+Lgk7QlyCn5c/EyRqHTziY9cVUoLXYZyc4xkX0mvnJMPMvD+au/Oe/uPh8Kz1TX'></script>
<link rel="https://api.w.org/" href="https://seattle.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://seattle.cbslocal.com/wp-json/wp/v2/posts/256433" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://seattle.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://seattle.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://cbsloc.al/3kXK16T' />
<link rel="alternate" type="application/json+oembed" href="https://seattle.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseattle.cbslocal.com%2F2021%2F07%2F26%2Froswell-new-mexico-season-3-premiere-the-cw-jeanine-mason-nathan-dean%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://seattle.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseattle.cbslocal.com%2F2021%2F07%2F26%2Froswell-new-mexico-season-3-premiere-the-cw-jeanine-mason-nathan-dean%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		
<meta property="og:title" content="&#039;Roswell, New Mexico&#039; Stars Jeanine Mason And Nathan Dean Prepare For Season 3 On The CW: &#039;This Season Is Wild&#039;" /><meta property="og:image" content="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/jeaninemason-55.jpg?w=1045" /><meta property="og:image:secure_url" content="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/jeaninemason-55.jpg?w=1045" /><meta property="og:image:width" content="1045" /><meta property="og:image:height" content="587" /><meta property="og:description" content="Tune in for &#039;Roswell, New Mexico&#039; tonight at 8/7c on The CW." /><meta property="og:type" content="article" /><meta property="og:url" content="https://seattle.cbslocal.com/2021/07/26/roswell-new-mexico-season-3-premiere-the-cw-jeanine-mason-nathan-dean/" /><meta property="article:published_time" content="2021-07-26T05:30:12+00:00" /><meta property="article:suggested-social-copy" content="Tune in for &#039;Roswell, New Mexico&#039; tonight at 8/7c on The CW." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="CBS+" /><meta property="article:publisher" content="https://www.facebook.com/CW11Seattle/" /><meta property="article:author" content="https://www.facebook.com/CW11Seattle/" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/jeaninemason-55.jpg?w=1045"><meta name="twitter:title" content="&#039;Roswell, New Mexico&#039; Stars Jeanine Mason And Nathan Dean Prepare For Season 3 On The CW: &#039;This Season Is Wild&#039;"/><meta name="twitter:description" content="Tune in for &#039;Roswell, New Mexico&#039; tonight at 8/7c on The CW."/><meta name="twitter:site" content="/CW11Seattle/"/>
<link rel="canonical" href="https://seattle.cbslocal.com/2021/07/26/roswell-new-mexico-season-3-premiere-the-cw-jeanine-mason-nathan-dean/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://seattle.cbslocal.com/2021/07/26/roswell-new-mexico-season-3-premiere-the-cw-jeanine-mason-nathan-dean/?amp">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/seattle.cbslocal.com","url":"https:\/\/seattle.cbslocal.com","name":"CBS Seattle","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/seattle.cbslocal.com\/wp-content\/uploads\/sites\/15909838\/2018\/06\/2_cbs_seattle.png?w=209"}},"url":"https:\/\/seattle.cbslocal.com\/2021\/07\/26\/roswell-new-mexico-season-3-premiere-the-cw-jeanine-mason-nathan-dean\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/seattle.cbslocal.com\/2021\/07\/26\/roswell-new-mexico-season-3-premiere-the-cw-jeanine-mason-nathan-dean\/"},"headline":"&#8216;Roswell, New Mexico&#8217; Stars Jeanine Mason And Nathan Dean Prepare For Season 3 On The CW: &#8216;This Season Is Wild&#8217;","description":"Tune in for 'Roswell, New Mexico' tonight at 8\/7c on The CW.","image":"https:\/\/seattle.cbslocal.com\/wp-content\/uploads\/sites\/15909838\/2021\/07\/jeaninemason-55.jpg?w=1045","keywords":["CBS+","Roswell New Mexico","'Roswell, New Mexico' Stars Jeanine Mason And Nathan Dean Prepare For Season 3 On The CW: 'This Season Is Wild'"],"datePublished":"2021-07-26T05:30:12+00:00","dateModified":"2021-07-26T05:30:12+00:00"}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.SEATTLE","default",["roswellnewmexicostarsjeaninemasonandnathandeanprepareforseason3onthecwthisseasoniswild","post","article","cbs","roswellnewmexico","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("3");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-2438645-64" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-2438645-64" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"cbs;","dimension2":"article"});gtag("config","UA-2438645-64");</script>

		<style type="text/css" id="wp-custom-css">
			
.single-post sup {
	vertical-align: super;
	font-size: 10px;
}

.postid-244620  .partner-container{
	display: none;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="Tune in for &#039;Roswell, New Mexico&#039; tonight at 8/7c on The CW." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-256433 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://seattle.cbslocal.com" id="header-logo"><img src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/06/2_cbs_seattle.png?w=209" alt="CBS Seattle" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper"><div id="embed-list-1" class="embed-item embed-list column-count-1 block-type-wpmenu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">News</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="http://seattle.cbslocal.com/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="http://seattle.cbslocal.com/live" title="Live Videos" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Live Videos</strong></div></a><a href="http://seattle.cbslocal.com/photo-galleries/" title="Galleries" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Galleries</strong></div></a><a href="http://seattle.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="http://seattle.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a></div>
</div></div><div id="embed-list-2" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Best Of</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://seattle.cbslocal.com/2020/05/22/quarantine-cooking-nonstick-cookware-guide/" title="Quarantine Cooking: Your Essential Nonstick Cookware Guide" class="cbs-thumbnail-link item-1590161120" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/nonstickpans.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Cooking: Your Essential Nonstick Cookware Guide</strong><em class="description">Step up your quarantine cooking with this guide to nonstick cookware.</em></div></a><a href="https://seattle.cbslocal.com/2020/05/22/how-to-6-easy-steps-to-make-homemade-soft-pretzels/" title="How To: 6 Easy Steps To Make Homemade Soft Pretzels" class="cbs-thumbnail-link item-1590161082" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2020/05/homemadepretzel.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How To: 6 Easy Steps To Make Homemade Soft Pretzels</strong><em class="description">Learn how to make your own homemade soft pretzels with these six easy steps!</em></div></a></div>
</div></div><div id="embed-list-3" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Travel</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://seattle.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/08/GettyImages-466663843-17.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://seattle.cbslocal.com/2019/06/13/top-3-eco-friendly-vacation-spots/" title="Top 3 Eco-Friendly Vacation Spots" class="cbs-thumbnail-link item-1560449704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/06/gettyimages-598645380-e1537896793352.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 3 Eco-Friendly Vacation Spots</strong><em class="description">Check out the three best spots for an eco-friendly vacation!</em></div></a></div>
</div></div><div id="embed-list-4" class="embed-item embed-list enable-type-icons column-count-1 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">CBS Entertainment</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="http://seattle.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-1519667323" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/02/CBS.png?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS+</strong></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="http://seattle.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-5" class="embed-item embed-list column-count-1 block-type-wpmenu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">All Sports</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="http://www.cbssports.com/college-football/" title="NCAAF" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">NCAAF</strong></div></a></div>
</div></div><div id="embed-list-6" class="embed-item embed-list enable-type-icons column-count-3 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Featured Sports</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://seattle.cbslocal.com/2021/07/26/olympics-2021-uswnt-australia-things-to-know/" title="Olympics 2021: USWNT Vs. Australia, 5 Things Fans Should Know" class="cbs-thumbnail-link item-1627305704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/GettyImages-1330397778.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Olympics 2021: USWNT Vs. Australia, 5 Things Fans Should Know</strong><em class="description">One match left for the Americans in the group stage and another familiar opponent stands in the way of a knockout stage berth.</em></div></a><a href="https://seattle.cbslocal.com/2021/07/23/olympics-2021-uswnt-new-zealand-match-facts/" title="Olympics 2021: USWNT Vs. New Zealand 5 Things To Know" class="cbs-thumbnail-link item-1627083051" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/GettyImages-1329848157.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Olympics 2021: USWNT Vs. New Zealand 5 Things To Know</strong><em class="description">After a stunning loss in their opener, the USWNT look to rebound against New Zealand in their second group match. Here&#039;s what you should know.</em></div></a><a href="https://seattle.cbslocal.com/2021/07/23/amber-mckenzie-athletes-unlimited-lacrosse/" title="&#039;My Kids Get To See All These Amazing Women&#039;: Amber McKenzie On Athlete Unlimited Lacrosse" class="cbs-thumbnail-link item-1627064187" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/athletes-unlimited-e1627062002613.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;My Kids Get To See All These Amazing Women&#039;: Amber McKenzie On Athlete Unlimited Lacrosse</strong><em class="description">The star lacrosse player talks with us about the new professional women&#039;s lacrosse league and the impact this will have on the next generation of young girls playing the sport.</em></div></a></div>
</div></div><div id="embed-list-7" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Latest Galleries</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://seattle.cbslocal.com/photo-galleries/2021/01/26/remembering-hank-aaron/" title="Remembering Hank Aaron" class="cbs-thumbnail-link item-1611694661 content-type-photo" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Remembering Hank Aaron</strong></div></a><a href="https://seattle.cbslocal.com/photo-galleries/2017/11/12/falk-throws-3-tds-no-19-washington-state-beats-utah-33-25/" title="Falk throws 3 TDs, No. 19 Washington State beats Utah 33-25" class="cbs-thumbnail-link item-1510499358 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2017/11/gettyimages-873591258_master.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Falk throws 3 TDs, No. 19 Washington State beats Utah 33-25</strong><em class="description">Luke Falk threw for 311 yards and three touchdowns and No. 19 Washington State beat Utah 33-25 on Saturday.</em></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-2 w-link"><a href="http://seattle.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a></li><li class="menu-top-item item-3 w-link"><a href="https://seattle.cbslocal.com/live/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://seattle.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CBS+</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-8" class="embed-item embed-list enable-type-icons column-count-6 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Latest Headlines</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://seattle.cbslocal.com/2021/07/26/major-league-rugby-cbs-how-to-watch/" title="Major League Rugby Championship Featuring Rugby ATL Against L.A. Giltinis On CBS Sunday August 1" class="cbs-thumbnail-link item-1627324133" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Major League Rugby Championship Featuring Rugby ATL Against L.A. Giltinis On CBS Sunday August 1</strong><em class="description">The Major League Rugby championship is set for this weekend in Los Angeles and CBS Sports will have live coverage.</em></div></a><a href="https://seattle.cbslocal.com/2021/07/26/roswell-new-mexico-season-3-premiere-the-cw-jeanine-mason-nathan-dean/" title="&#039;Roswell, New Mexico&#039; Stars Jeanine Mason And Nathan Dean Prepare For Season 3 On The CW: &#039;This Season Is Wild&#039;" class="cbs-thumbnail-link item-1627302612" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/jeaninemason-55.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;Roswell, New Mexico&#039; Stars Jeanine Mason And Nathan Dean Prepare For Season 3 On The CW: &#039;This Season Is Wild&#039;</strong><em class="description">Tune in for &#039;Roswell, New Mexico&#039; tonight at 8/7c on The CW.</em></div></a><a href="https://seattle.cbslocal.com/2021/07/23/love-island-genevieve-shawcross-andrew-phillips-new-episode-cbs/" title="&#039;Love Island&#039; Welcomes Genny Shawcross, Flo Money And 8 Others This Sunday Night On CBS" class="cbs-thumbnail-link item-1627065123" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/117654_28025bc.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;Love Island&#039; Welcomes Genny Shawcross, Flo Money And 8 Others This Sunday Night On CBS</strong><em class="description">Catch an all-new &#039;Love Island&#039; this Sunday on CBS and streaming with the CBS App or Paramount+.</em></div></a><a href="https://seattle.cbslocal.com/2021/07/23/stephen-king-billy-summers-release-exclusive/" title="Stephen King To Read An Exclusive Scene From Upcoming Novel ‘Billy Summers’" class="cbs-thumbnail-link item-1627043417" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/billysummers1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Stephen King To Read An Exclusive Scene From Upcoming Novel ‘Billy Summers’</strong><em class="description">This worldwide event, with King narrating a never-before-released selection, will offer fans a sneak peek at the book before it’s published on August 3 by Scribner Books (a Simon &amp; Schuster/ViacomCBS company).</em></div></a><a href="https://seattle.cbslocal.com/2021/07/22/nathan-kress-icarly-paramount-plus-interview/" title="Nathan Kress On Paramount+&#039;s &#039;iCarly&#039;: &#039;We Were Kind Of Ahead Of Our Time&#039;" class="cbs-thumbnail-link item-1626959956" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/iCarly_101_istartover_RT_011-e1626959550427.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Nathan Kress On Paramount+&#039;s &#039;iCarly&#039;: &#039;We Were Kind Of Ahead Of Our Time&#039;</strong><em class="description">The hit Nickelodeon series &quot;iCarly&quot; is back in a brand new way on Paramount+. Actor Nathan Kress tells us what it was like to play Freddie Benson again.</em></div></a><a href="https://seattle.cbslocal.com/2021/07/21/lorne-michaels-bette-midler-joni-mitchell-kennedy-center-honorees/" title="Lorne Michaels, Bette Midler, Joni Mitchell, Justino Díaz &amp; Berry Gordy Announced As 2021 Kennedy Center Honorees" class="cbs-thumbnail-link item-1626894527" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/bette.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Lorne Michaels, Bette Midler, Joni Mitchell, Justino Díaz &amp; Berry Gordy Announced As 2021 Kennedy Center Honorees</strong><em class="description">This year&#039;s class features the creator of Saturday Night Live, a legendary actor, an extraordinary singer, an operatic bass-baritone and a Motown producer and songwriter.</em></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-5 w-link"><a href="http://cwseattle.cbslocal.com/" title="CW 11" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CW 11</strong></div></a></li><li class="menu-top-item item-6 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">More</strong></div></div><div class="submenu"><div class="wrapper"><div id="embed-list-9" class="embed-item embed-list enable-type-icons column-count-5 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="http://seattle.cbslocal.com/category/travel/">Travel</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://seattle.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/08/GettyImages-466663843-17.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://seattle.cbslocal.com/2019/06/13/top-3-eco-friendly-vacation-spots/" title="Top 3 Eco-Friendly Vacation Spots" class="cbs-thumbnail-link item-1560449704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/06/gettyimages-598645380-e1537896793352.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 3 Eco-Friendly Vacation Spots</strong><em class="description">Check out the three best spots for an eco-friendly vacation!</em></div></a><a href="https://seattle.cbslocal.com/2019/04/04/final-four-guide-top-10-instagram-worthy-spots-in-minneapolis/" title="Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis" class="cbs-thumbnail-link item-1554411634" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/04/igworthy.png?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis</strong><em class="description">With thousands of Final Four fans heading to downtown Minneapolis in the coming days, you better believe the Instagram filters will be flying.</em></div></a><a href="https://seattle.cbslocal.com/2019/04/04/final-four-guide-best-breweries-minneapolis/" title="Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis" class="cbs-thumbnail-link item-1554411465" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/04/187774436.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis</strong><em class="description">Beer-lovers visiting Minneapolis for the Final Four won’t have to go far to find Minnesota’s most beloved beers. Walk in any direction out of U.S. Bank Stadium and you’ll probably find a bar or restaurant serving craft beers from the Twin Cities, the North Shore and other parts of “The Land of 10,000 Beers.&quot; But for hop heads seeking a more direct experience of the state’s brewing culture, there are a few places that need to be on your radar, because they’re well worth the Lyft ride.</em></div></a><a href="https://seattle.cbslocal.com/2019/04/04/final-four-guide-5-restaurants-near-u-s-bank-stadium/" title="Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium" class="cbs-thumbnail-link item-1554410992" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/04/107277389-e1538670804895.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium</strong><em class="description">In Minneapolis for the Final Four and want to try the restaurants where Minneapolitans love to eat? Look no further. Below are some of the most beloved spots in the City of Lakes within walking distance, or a short Lyft ride, from U.S. Bank Stadium.</em></div></a></div>
</div></div><div id="embed-list-10" class="embed-item embed-list enable-type-icons column-count-1 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">More</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="http://seattle.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-1519667323" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://seattle.cbslocal.com/wp-content/uploads/sites/15909838/2018/02/CBS.png?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS+</strong></div></a></div>
</div></div></div></div></li></ul></nav>
	
	
	<div id="info-search"><form action="https://seattle.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size='[[970,250],[970,66],[728,90]]' data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">&#8216;Roswell, New Mexico&#8217; Stars Jeanine Mason And Nathan Dean Prepare For Season 3 On The CW: &#8216;This Season Is Wild&#8217;</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">July 26, 2021 at 5:30 am</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://seattle.cbslocal.com/tag/roswell-new-mexico/">Roswell New Mexico</a></div></div></section><section id="column_block_11" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div class="anvato-iframe-wrapper"><div id="p0"></div></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"5823072","autoplay":true,"titleVisible":false,"accessKey":"5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5","customMetadata":{"video":{"cbs_market":"seattle.cbslocal.com","cbs_platform":"desktop"}}},"comscore":{"clientId":"3000023","c3":"Seattle.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/CBS.SEATTLE&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}}},"shareLink":"https:\/\/cbsloc.al\/3kXK16T","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5});});});</script></div></section>
<div class="main-story-wrapper"><p><strong>(CBS) &#8211;</strong> <em>Roswell, New Mexico</em> returns for season three tonight on The CW at 8/7c. CBS&#8217; Matt Weiss caught up with two of the show&#8217;s stars, Jeanine Mason and Nathan Dean to get the inside story on everything coming up in the show&#8217;s third premiere.</p>
<p><strong>MW:</strong> Jeanine, Nathan nice to see you both! Season three of <a href="https://www.cwtv.com/shows/roswell-new-mexico/the-diner/?play=bbf21988-a7a8-4c36-9235-e95cade0915c" target="_blank" rel="nofollow"><em>Roswell, New Mexico</em></a> coming up tonight at 8/7c on The CW. How does it feel to be back?</p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://seattle.cbslocal.com/2021/07/26/stimulus-check-update-fourth-payment-covid/" target="_blank">Fourth Stimulus Check: Will There Be Additional Relief Payments?</a>
<p><strong>JM:</strong> It feels so good. The timing of our show rolling out as the pandemic started in the States at least, was real a blessing because we could connect to our fans and give them a little labor of love of ours in the midst of a really difficult time.</p>
<p>It also meant that we had a little bit more time before we could start back up. It&#8217;s truly been a year and everybody is so excited. It&#8217;s an actual year of change for our characters. Kind of nice even though we know everybody is ready to see it.</p>
<p><strong>ND:</strong> It&#8217;s hard to believe that we were able to pull this off with everything that everyone&#8217;s had to go through. That&#8217;s a credit to our showrunner Chris Hollier and to our amazing, amazing crew in New Mexico that we were able to not only get this thing started but not get stopped, not get cut short. We were able to create a product that we can now say, hey guys, we&#8217;re back, hope you&#8217;re all doing well.</p>
<p><strong>JM:</strong> Back on Mondays!</p>
<p><strong>ND:</strong> Here we are!</p>
<p><strong>MW:</strong> I know the fans are all very excited. Jeanine, like you mentioned a year has passed since we&#8217;ve seen all your characters particularly Liz. How are things going for her in Los Angeles?</p>
<p><strong>JM:</strong> Liz is per usual really focused, head in her work to save Maria. She hasn&#8217;t quite taken the time to realize her life in LA is pretty good. It&#8217;s even keeled, we&#8217;ll say. She&#8217;s got a great place, she&#8217;s got a great job, that gives her access to everything she needs and requires to do her best work, to make her best contribution to health and medicine.</p>
<p>She&#8217;s got a real meeting of the minds in her lab partner played by Steven Krueger, Heath is his name. He matches her in intellect and in sarcasm in a way that&#8217;s really fun. They sort of really spar with each other.</p>
<p>The truth of the matter is, Liz is a woman who&#8217;s made to give to her community. She&#8217;s missing Roswell,&nbsp; she&#8217;s missing her people, she&#8217;s missing Max Evans. She finds her way back to what is ultimately her real purpose, which is working with and for them.</p>
<p>Pretty quickly we find&nbsp; out how dire things are there for our alien trio. As soon as she finds out things are bad of course she&#8217;s miss hero protagonist. She wants to get involved and save the day.</p>
<p><strong>MW:</strong> Nathan, pulling double duty on this season, with two characters, what&#8217;s that experience like?</p>
<p><strong>ND:</strong> It was wild. It was a blast and I&#8217;m still grateful to Hollier and all of our writers for trusting me with that. Diving into it, it&#8217;s so fun to create a new character. In this world that I&#8217;ve known now for three years and meeting everyone in this town again for the first time, from a completely different perspective.</p>
<p>It was a lot fun. It was a lot of work. It&#8217;s a very weird process doing scenes with yourself because you&#8217;re joking back and forth. It&#8217;s really fun though. I&#8217;m so grateful to our showrunner and our writers for trusting me with that.</p>
<p><strong>MW:</strong> I&#8217;m sure it&#8217;s confusing talking to yourself and also as part of that Max doesn&#8217;t even really know a lot about his own history. Are we going to get more light shed on that this season?</p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://seattle.cbslocal.com/2021/07/23/stimulus-check-fourth-update-covid-pandemic-payment/" target="_blank">Fourth Stimulus Check: Will There Be Another Relief Payment?</a>
<p><strong>ND:</strong> That&#8217;s one of the wonderful things that Jones embodies is he&#8217;s sort of the window into the past of these three aliens. Since last season Michael, Isobel, and Max have always had that question. Who am I? Who are we? Where do we come from? Jones is a little peak into what that world was.</p>
<p>Also, a little example of who Max could&#8217;ve been had he not grown up on Earth and it&#8217;s sort of cool to see the humanity that Max has grown up in versus the sort of Alien world that Jones was in. We&#8217;re going to learn a little bit more about where we come from.</p>
<p><strong>MW:</strong> Jeanine, for Liz how do you think she&#8217;ll be with Max this season? Do you think she&#8217;ll be able to forgive everything that went down with the lab?</p>
<p><strong>JM:</strong> I just want to tell you. [Laughs] But that would be spoiling the fun of watching I assume. I guess what I&#8217;ll say is so much of her life has been decided for her. She is the answer to the Earth&#8217;s need for a protector and steward So much of her own opinions on it haven&#8217;t been taken into account yet. This is really the season where she just needs to for herself make the decision to take on this huge responsibility and that it feel like what makes most sense for her and her life.</p>
<p>So quickly she starts finding her way back. I love that she&#8217;s not a perfect protagonist. No one is perfect. No one is squeaky clean. She loves the complication. She loves that her life is so big and messy and loaded. She has huge grounding forces.</p>
<p>For her it&#8217;s Max and it&#8217;s Roswell and it&#8217;s her community. She finds her way back to a very big messy situation with Jones and falls into that rhythm really fast and starts making choices on where she wants to&#8230; I&#8217;ll say this, by the end of the season she&#8217;s made a decision that&#8217;s permanent. Ok, that&#8217;s it. [laughs]</p>
<p><strong>MW:</strong> I mean it would be a great exclusive, so if you want to just tell me everything go right ahead! [Laughs]</p>
<p><strong>JM:</strong> Just so you know. It&#8217;s my favorite Liz and Max season. It really is the one where they make their final decision with each other. That&#8217;s it, because if I say another thing I&#8217;m going to get in trouble. [Laughs]</p>
<p><strong>MW:</strong> We don&#8217;t want that, you&#8217;re good! Last question for you both here, what are you most excited for people to see?</p>
<p><strong>ND:</strong> I don&#8217;t know. I think for me it&#8217;s just awesome to be back. This season is wild. There&#8217;s a lot more of the alien stuff. We get to see more from all of the characters; a more adult mature experience and reaction to their world.</p>
<p><strong>JM:</strong> It felt like such a gift to get a third go at this. That&#8217;s not an easy thing in this current television landscape. I think you can feel our enthusiasm throughout the year where we were just so excited to be back. We were just throwing things at the wall and trying everything and going full out.</p>
<p>By the end the of this season we were all so beat up and I mean that positively. That&#8217;s my favorite kind of way to finish the season, when you feel it physically; you&#8217;ve exhausted yourself. Our stunt team was just on call every minute of this season this year. I&#8217;m excited for the action and the enthusiasm I hope fans feel from all of us getting to finally be back doing what we do.</p>
<p><strong>MW:</strong> Thank you both so much for the time and all the best moving forward. Stay safe!</p>
<p><strong>JM:</strong> You too, stay safe!</p>
<p><strong>ND:</strong> Thank you.</p><strong style="color: black; float: left; padding-right: 5px;">MORE NEWS: </strong><a style="display: block; margin-bottom: 25px;" href="https://seattle.cbslocal.com/2021/07/19/stock-market-drop-covid-delta-variant-slowing-recovery/" target="_blank">Stock Market Plummets Amidst Growing Fears Of COVID&#039;s Delta Variant</a>
<p>Tune in for <em>Roswell, New Mexico</em> at 8/7c on The CW. Check your local listings for more information.</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3kXK16T"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3kXK16T"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3kXK16T"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size='[[1,5],"fluid"]' data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-12"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size='[[300,250],[300,600],[300,1050]]' data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CW11Seattle/" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/CW11Seattle/" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://seattle.cbslocal.com/2012/07/02/best-places-for-u-pick-cherries-in-wa/" title="Best Places for U-Pick Cherries in WA " class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2012/07/38120_144836508861914_232570_n.jpg?resize=55%2C55&#038;ssl=1" alt="Best Places for U-Pick Cherries in WA " data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2012/07/02/best-places-for-u-pick-cherries-in-wa/" title="Best Places for U-Pick Cherries in WA " class="bump-view" data-bump-view="tp">Best Places for U-Pick Cherries in WA </a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2012/08/10/best-u-pick-peaches-in-washington/" title="Best U-Pick Peaches in Washington " class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2012/08/peaches-2010.jpg?resize=55%2C55&#038;ssl=1" alt="Best U-Pick Peaches in Washington " data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2012/08/10/best-u-pick-peaches-in-washington/" title="Best U-Pick Peaches in Washington " class="bump-view" data-bump-view="tp">Best U-Pick Peaches in Washington </a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2015/09/11/5-states-without-major-sports-teams/" title="5 States Without Major Sports Teams" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2015/09/gettyimages-152712410.jpg?resize=55%2C55&#038;ssl=1" alt="5 States Without Major Sports Teams" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2015/09/11/5-states-without-major-sports-teams/" title="5 States Without Major Sports Teams" class="bump-view" data-bump-view="tp">5 States Without Major Sports Teams</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2021/07/09/olympics-2021-how-when-to-watch-usa-mens-basketball/" title="Olympics 2021: How, When To Watch USA Men&#039;s Basketball" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/GettyImages-1327374770.jpg?resize=55%2C55&#038;ssl=1" alt="Olympics 2021: How, When To Watch USA Men&#039;s Basketball" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2021/07/09/olympics-2021-how-when-to-watch-usa-mens-basketball/" title="Olympics 2021: How, When To Watch USA Men&#039;s Basketball" class="bump-view" data-bump-view="tp">Olympics 2021: How, When To Watch USA Men&#039;s Basketball</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2021/07/13/10-must-read-books-summer-beach-list/" title="10 Must-Read Books For Every Summer Reading List" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/tropicbeach.jpg?resize=55%2C55&#038;ssl=1" alt="10 Must-Read Books For Every Summer Reading List" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2021/07/13/10-must-read-books-summer-beach-list/" title="10 Must-Read Books For Every Summer Reading List" class="bump-view" data-bump-view="tp">10 Must-Read Books For Every Summer Reading List</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2021/07/12/ronny-chieng-the-daily-show-interview/" title="&#039;Trevor Noah Wanted To Give Asian People A Voice&#039;: Ronny Chieng On &#039;The Daily Show With Trevor Noah&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/GettyImages-946688150-e1626113259596.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;Trevor Noah Wanted To Give Asian People A Voice&#039;: Ronny Chieng On &#039;The Daily Show With Trevor Noah&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2021/07/12/ronny-chieng-the-daily-show-interview/" title="&#039;Trevor Noah Wanted To Give Asian People A Voice&#039;: Ronny Chieng On &#039;The Daily Show With Trevor Noah&#039;" class="bump-view" data-bump-view="tp">&#039;Trevor Noah Wanted To Give Asian People A Voice&#039;: Ronny Chieng On &#039;The Daily Show With Trevor Noah&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2021/07/14/las-vegas-stockton-flight-allegiant-17-hours/" title="Flight From Hell: Passengers Land In Stockton 17 Hours After Taking Off From Las Vegas" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/snapshot-43.jpg?resize=55%2C55&#038;ssl=1" alt="Flight From Hell: Passengers Land In Stockton 17 Hours After Taking Off From Las Vegas" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2021/07/14/las-vegas-stockton-flight-allegiant-17-hours/" title="Flight From Hell: Passengers Land In Stockton 17 Hours After Taking Off From Las Vegas" class="bump-view" data-bump-view="tp">Flight From Hell: Passengers Land In Stockton 17 Hours After Taking Off From Las Vegas</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2021/07/14/breaking-the-stigma-cindy-hsu-interview/" title="Breaking The Stigma: CBS Anchor Cindy Hsu Shares Her Most Personal Story About Mental Health Battle" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/Cindy-Hsu.jpg?resize=55%2C55&#038;ssl=1" alt="Breaking The Stigma: CBS Anchor Cindy Hsu Shares Her Most Personal Story About Mental Health Battle" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2021/07/14/breaking-the-stigma-cindy-hsu-interview/" title="Breaking The Stigma: CBS Anchor Cindy Hsu Shares Her Most Personal Story About Mental Health Battle" class="bump-view" data-bump-view="tp">Breaking The Stigma: CBS Anchor Cindy Hsu Shares Her Most Personal Story About Mental Health Battle</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2021/07/07/tpc-deere-run-profile/" title="TPC Deere Run Profile: John Deere Classic Home &#039;A Good, Straight-Forward Golf Course&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2019/07/tpc-deere-run-4th-hole-1.jpg?resize=55%2C55&#038;ssl=1" alt="TPC Deere Run Profile: John Deere Classic Home &#039;A Good, Straight-Forward Golf Course&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2021/07/07/tpc-deere-run-profile/" title="TPC Deere Run Profile: John Deere Classic Home &#039;A Good, Straight-Forward Golf Course&#039;" class="bump-view" data-bump-view="tp">TPC Deere Run Profile: John Deere Classic Home &#039;A Good, Straight-Forward Golf Course&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://seattle.cbslocal.com/2021/07/12/cbs-fall-lineup-2021-premieres-48-hours-big-brother/" title="FULL LIST: 60 Minutes, Survivor And The 73rd Emmy Awards Live Highlight CBS Fall Lineup" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/seattle.cbslocal.com/wp-content/uploads/sites/15909838/2021/07/image002-19.jpg?resize=55%2C55&#038;ssl=1" alt="FULL LIST: 60 Minutes, Survivor And The 73rd Emmy Awards Live Highlight CBS Fall Lineup" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://seattle.cbslocal.com/2021/07/12/cbs-fall-lineup-2021-premieres-48-hours-big-brother/" title="FULL LIST: 60 Minutes, Survivor And The 73rd Emmy Awards Live Highlight CBS Fall Lineup" class="bump-view" data-bump-view="tp">FULL LIST: 60 Minutes, Survivor And The 73rd Emmy Awards Live Highlight CBS Fall Lineup</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size='[[300,250]]' data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size='[[728,90]]' data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
										<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CW11Seattle/" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/CW11Seattle/" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			<div id="block-0" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Entertainment</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="http://seattle.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">CBS+</strong></div></a><a href="https://seattle.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://seattle.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Travel</strong></div></a><div class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div><div id="block-1" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Corporate</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="http://seattle.cbslocal.com/about-us/" title="About Us" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">About Us</strong></div></a><a href="http://seattle.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><div class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div>		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://seattle.cbslocal.com" class="logo"><img src="https://seattle.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-viacom-logo-white.png" alt="CBS Seattle" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2021 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=seattle.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-50590" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50590"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-50591" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50591"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-245005" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245005"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-245006" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245006"><a href="https://ca.privacy.cbs/donotsell">Do Not Sell My Personal Information</a></li>
<li id="menu-item-175000" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-175000"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size='[[1,8]]' data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size='[[1,6]]' data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size='[[1,7]]' data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='screen-css-0' href='https://seattle.cbslocal.com/_static/??-eJzTLy/QTc7PK0nNK9EvyUjNTS3WT04q1s3JT07M0c/MS84pTQEKpeYmpaYAZYqhTN2czOISPSBXR598/brpRZkpFBuSnJ9bkJgMdox9rq2hmZGZuaGZoaUZAIi9T2c=' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://seattle.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1626716196g' type='text/css' media='all' />
<script id='jetpack-facebook-embed-js-extra'>
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
</script>
<script type='text/javascript' src='https://seattle.cbslocal.com/_static/??-eJyVjUEOwjAMBD+E4xaJVj0gnoKaxCCnsRMRR/0+5dYrx5VmZnGvEIoaqaF0qLm/WRsmsrqGDRa34JM1oO+cI77WQL6UDUg8RSesLrUL/tWwnc3oA8ZCmZXOlYPKPdLhtt88vzzkPk7XeZiH2zilL/t3QSs='></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.7.2' id='cbs-cbs-anvato-js'></script>
<script src='https://stats.wp.com/e-202130.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.9.1',blog:'162246008',post:'256433',tz:'-7',srv:'seattle.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246008', '256433' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>